Support » Plugin: Yoast SEO » How to disable Yoast SEO adding article:author meta tags to pages?

  • Resolved xealpha


    The Yoast SEO plugin is adding some unwanted meta tags.

    I would like article:author to appear on posts only, but not on pages or other content types. When we share a page on our Facebook, Yoast automatically shows: | | By AuthorName
    How do I disable that for pages only, globally?


Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Pcosta88



    Yoast does not have the ability to remove that author tag on specific post-types. However, we thank you for suggesting a new feature for one of our plugins. We’re not working on it at the moment but we’ll create a feature request for this, so our developers can consider this when planning updates.

    You can follow it here:

    We suggest commenting on the issue so you may be kept aware of any updates. You may need to create a GitHub account in order to post.

    In the meantime, we suggest developing the ability. Though, there’s a difference between the support we can offer and the level of programming needed to change (core) features of our plugin. Since we don’t want to take the risk that we break your website by suggesting incorrect or incomplete code, we cannot advise you on how to make such changes. And even though we cannot be of any assistance, you’re completely free to change anything in the plugin to better suit your needs.

    We highly recommend checking out Code Poet ( ) for available freelance WordPress developers and Human Made ( ) for development & consultancy.

    Alternatively, perhaps a developer watching these forums can assist further.



    I thought this would be a very basic feature of Yoast!

    Can you imagine the name of the author appearing when you share pages? that’s very bad for social media sharing.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘How to disable Yoast SEO adding article:author meta tags to pages?’ is closed to new replies.