Support » Fixing WordPress » How to disable “Welcome to the Block Editor” Option

  • Hello,

    “Welcome to the Block Editor” pop up box is coming when adding new post and editing old posts.

    Please let me know how to disable “Welcome to the Block Editor” option.

    Thanks.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Once you dismiss it, it won’t re-appear.

    But it does reappear, every fecking page I go in to, it will come up. I

    Same problem for me Lewis. I’ve dimissed it a hundred times, and it just keeps coming back each. and. every. time. I. open. a. page. Driving me nuts!

    You’re not alone!

    Here, too – I was about to ask the forum. This pop-up is so annoying!

    Good to know it’s not just me. Really fustrating. Why is this not working?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    What browser are you using? What operating system?

    Do you have any privacy software running? Do you know if “LocalStorage” is disabled in this browser?

    Thread Starter ExactFox

    (@exactfox)

    What browser are you using?

    Google Chrome and Firefox.

    What operating system?

    Windows 10.

    Do you have any privacy software running?
    No.

    Do you know if “LocalStorage” is disabled in this browser?
    Not disabled.

    Thanks.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Well, if the message is coming back over and over again, then something is clearing your browser’s memory. The browser is supposed to remember that you dismissed the message, and thus not display it again.

    So, maybe see what happens in different browsers. Figure out what is unusually configured about your normal browser.

    Why is it stored as a browser cookie rather than stored to the database so it NEVER comes back regardless of my browser?

    Please consider making it so that when dismissed the dismissal is stored in the db and not the browser.

    In my limited understanding I assume this is the way that dismissals of eg notices from plugins are stored. I do not re-see a dismissed notice of a plugin.

    In my case, for security purposes I clear cookies and site data etc on exit. It is a standard setting in Preferences of Firefox. It is meant for privacy and security.

    I also got this notice EVERY time I create a new page, in a new tab, even within the same session of FF.

    I have setup Firefox to have independent containers for each page/tab so if you visit your own site in one page, it will set a cookie, but if you open a second page/tab to work on the site, that tab will not have the cookie in it. I believe this is why I see the same notice even within a single session of using FF.

    I resolved the issue within the same browser session by whitelisting my site in FF so that site data is not cleared. This may be a solution for other people posting in this issue.

    Have not fixed it as yet between sessions.

    Also I use different browsers eg at work and at home….

    Overall though I used to not like Gutenberg a year or more ago but in the last week I have started to use it and I must say I am starting to see the potential, I like it – Good job!

    Cheers and thanks!

    I agree that it should be stored in the database, just like practically every plugin. Why wordpress needs to be different in this regard and save it to a browser, when we live in a privacy concious world with many people choosing to browse privately or reguarly clear cookies, is beyond me. Very odd choice.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Why is it stored as a browser cookie

    It is not stored as a browser cookie, it is stored in “LocalStorage”. These are similar, but very different mechanisms.

    Please consider making it so that when dismissed the dismissal is stored in the db and not the browser

    That is the plan long term, however as the block editor is written more or less entirely in Javascript, then having it store data in LocalStorage is basically the default.

    The block editor exists entirely in the browser. It doesn’t run on the server. All the editing happens in the browser, and the data sent to the server is the completed post, more or less.

    So, to save such settings on the server, various other elements have to be added, and since not everything sticks around during development of the block editor, then those tend to get added only when things are really finalized. Storing settings for the editor in the database adds slowdown and overhead, basically. So it’s only done when those settings are perceived to be long term. Having a slow setting which might go away during further development adds long term maintenance issues. Having it local-only makes it easier to remove down the line, if it’s perceived as not useful.

    @otto42,

    Thanks very much for explaining more about why this is happening.

    As I said in an earlier post, my knowledge is limited 🙂

    It is good to understand more about why this is happening and why it would be difficult to implement a save in the db.

    So how do we disable this welcome message?
    Could we make it not show at all? Not even once?

    The welcome message should be disabled and removed outright if it cannot store in the site’s database which users have dismissed it.

    My browser is set to clear all data on close, but this happens with every page load. My LocalStorage thingy can’t be clearing out after every page load surely… and my cookies don’t either, even though not relevant to this case (and of course if cookies were clearing then I wouldn’t say logged in).

    Personally just feel like this welcome thingy has been badly implemented and would prefer maybe an admin panel widget or something that lets someone open it themselves. It should offer a tutorial rather than shove it in my face if it’s closure isn’t being stored in a database, in my opinion.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘How to disable “Welcome to the Block Editor” Option’ is closed to new replies.