Support » Fixing WordPress » How to Disable Visual Editor in The Text Widget

  • Resolved Siam

    (@siamlottery)


    I have javascript and style tags,
    And I would like to use the old text widget.
    Thank you.

    //Now 4.8.1 is resolved this problem
    Thanks again for WP team.

Viewing 15 replies - 1 through 15 (of 43 total)
  • Moderator Steve Stern

    (@sterndata)

    In short, there’s no way to undo it, but a stand-alone text-only widget will be part of the next WP release.

    Siam

    (@siamlottery)

    Thanks @sterndata
    Hope to see the next wp release soon.

    Moderator Steve Stern

    (@sterndata)

    Unless someone makes a plain text widget first!

    What are YOU doing this afternoon? 🙂

    Siam

    (@siamlottery)

    @sterndata
    Oh, now I found the plugin “Enhanced Text Widget”
    Thank you

    Can I possibly disable the visual editor in the new 4.8.0 widget? I need to go back to the other one. When I go into the widget I have coding that looks like this:

    Your Site<br>http://yoursite.tld“>

    It has converted to:

    Your Site<br>http://yoursite.tld“>

    I do not want all the <br> in the coding. I want to to go back to the original coding. With the stupid new “Enhanced Text Widget” I’ll have to go through all my sidebars in all my sites and disable the visual editor and then redo all the coding. It will be a major pain in the buttocks. Why can’t I when I disable the visual editor, it doesn’t go back to what I had?

    This is a major pain.

    Since this box converted what I typed to code, I’ll have to include a screengrab of what I mean:

    Advanced Widget Editor

    I’ve only updated two of my sites with 4.8, but I won’t be updating the rest until this is fixed.

    I agree this is a problem. Why is there a visual tab in a text widget? Isn’t that what Rich text widget is for? As soon as I updated to 4.8 many things broke that I had in my genesis widgets like SVG’s. The visual editor is a nuisance and there should be a way to disable this. When you go back and forth from text to visual is messes up your code. What is the solution?

    • This reply was modified 5 months, 2 weeks ago by  dambr7.

    I would have hoped when you disable the visual editor in your user profile, that would have disabled it site-wide. That’s why I disabled it in my user profile so I could actually create the code I wanted for the sidebar, particularly with the tooltip effect I wanted.

    With this I had to copy and paste from another site I had with the same coding that I hadn’t updated to 4.8, then put in the coding I’d attempted to put in on the site I’d updated, then in order for the changes to take effect you have to switch back to visual from text mode. Pain in the behind. There is a reason I hard code and shut off the visual editor on the site. I don’t need it imposed in an update we’re sort of forced into taking due to security issues, but no power to shut off the features we don’t want.

    @siamlottery “Enhanced Text Widget” plugin does seem to be the fix for now. Thanks!

    Still doesn’t fix the coding issue….. Why break something that didn’t need fixing?

    @nowordneeded
    You can remove automatic paragraphs in widgets by adding this code to your theme’s functions.php

    add_filter( 'widget_display_callback', 'clean_widget_display_callback', 10, 3 );
    function clean_widget_display_callback( $instance, $widget, $args ) {
        $instance['filter'] = false;
        return $instance;
    }

    @_regeek:

    That’s not the problem I’m having. The problem I’m having is that it completely changes my coding. While the result is the same on the webpage, the coding completely changes when I go from text to visual, which you have to do when you save it. The point is, I want complete control over the widget area in a box that should not be rich text or visual. I have rectified the issue by doing the downgrade on WP and updating the database. All is back to normal. I won’t update until this issue is corrected (hopefully) in the next release. But thank you for the work around.

    @nowordneeded
    Have you tried the code I provided?
    It keeps your custom code in widget intact, at least on my client website, which was just updated to 4.8.

    you can also use this filter in functions.php, although I did not tested that.
    remove_filter(‘widget_text_content’, ‘wpautop’);

    You may also want to disable Rich Edit completely in widgets, I am working on solution to this.

    If someone finds a solution to disable the visual editor on the text widgets, please let me know. Totally ruined my coding :/

    @pamdemel – Seems the bug will be addressed sooner or later.

Viewing 15 replies - 1 through 15 (of 43 total)
  • You must be logged in to reply to this topic.