Support » Plugin: WooCommerce » How to disable the “Connect your store to activate WooCommerce Shipping”

  • Resolved nootkan

    (@nootkan)


    I just installed and activated the woocommerce plugin but don’t want to use jetpack. I keep getting the notification in my dashboard and want to disable that as it is very annoying. Is this possible? Also does this mean that I cannot use another form of shipping with woocommerce other than jetpack? I need to know this before I go further as I want to use a different plugin for shipping. Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The core WooCommerce plugin does not produce notifications about jetpack. They must be coming from some other software element that you have, another plugin or your theme maybe.

    To test, disable other plugins and switch to the Storefront theme. That should stop those notifications. Then reactivate one-by-one to try to identify what’s causing them.

    Thanks for your reply. It seems something called woocommerce services was installed in my plugins folder when I installed woocommerce. I’ve deleted all and will start over to see if it happens again.

    After deleting and reinstalling I found a step that asks if you want to enable woocommerce shipping which I declined and the notifications disappeared. I must have missed this in the initial install.

    MakeOnlineShops

    (@makeonlineshops)

    Hello,

    I must have missed it also.
    This is anyway VERY VERY annoying to see this message in dashboard.
    So how to hide it without reinstalling ?

    Thank you.

    emgraphics

    (@emgraphics)

    I just deleted the “woocommerce services” plugin that was installed without my knowledge and the notice went away. Really cheap move there, woo.

    Thanks for the help emgraphics. Your solution led me to finding that there’s actually a WooCommerce Services plugin that can be deactivated/deleted from the plugin screen.

    Huge tip of the hat to y’all for saving me a lot of time on this. 😉

    Thank you!

    Bad move Woo. You now owe me for 30 minutes of wasted time.

    You do not have to install WooCommerce Connect and Jetpack to be able to use WooCommerce.

    What Woocommerce should simply do is to add text in the setup wizard like, “Connecting with Jetpack requires the Woocommerce Services plugin, which will now be installed. It can be safely removed later if desired. Is this OK?” That would fix everything.

    I think there’s a bunch of background info missing on why these plugins work the way they do in this thread:

    Automattic (WordPress company) recently bought WooCommerce and they have been merging the services since (for example you need a wordpress.com login for woocommerce.com now). Knowing this and knowing that JetPack is an Automattic plugin makes the connection make more sense.

    The WooCommerce Services plugin is not total BS as some have indicated here. If you like the services it offers like keeping your sales tax rates up to date automatically for the area you ship out of, then turn it on and connect it w/ JetPack. If you don’t need those things, just turn it off…

    The last thing that I discovered in learning more about this is how flexible and powerful carefully configured JetPack is. It really is pretty crappy and intrusive out of the box, but if you go to this settings screen, you can turn on only the features you want and disable the rest:
    [your-site-URL]/wp-admin/admin.php?page=jetpack_modules
    (this is available from the debug settings page too. not sure why they make this so hard to find!)

    If you like WooCommerce Services but think JetPack is too annoying and intrusive, try turning off all or almost all of the jetpack modules as suits your needs.

    Hey guys,

    This is really easy to fix. You do not need to install yet another plugin.

    Add just this line to your functions file.

    add_filter( 'woocommerce_helper_suppress_admin_notices', '__return_true' );

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘How to disable the “Connect your store to activate WooCommerce Shipping”’ is closed to new replies.