WordPress.org

Support

Support » Themes and Templates » Vantage » How to disable sticky menu at mobile browser

How to disable sticky menu at mobile browser

  • Hi Greg,

    Thank you for your wonderful themes.
    I am using vantage free themes and I would like to ask on how to disable sticky menu only at mobile browser, so I can still use the sticky menu on desktop browser. Is it possible or I must upgrade to pro version?

    Thank you for your kind attention and looking forward for your feedback.

    Regards,
    Febi

Viewing 6 replies - 1 through 6 (of 6 total)
  • I had the same question, and this is how I did it. I made a child theme containing this css:

    @media (max-width: 680px) {
    .site-navigation.main-navigation.use-sticky-menu.sticky {display:none;}
    }

    If anyone has a better solution, I’d be curious to know, but it seems to work well.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    @carklob, What about doing the same thing but positioning it static? So that the ‘top‘ CSS styles that are applied through JS have no effect?
    E.g.:

    @media (max-width: 680px) {
     .site-navigation {
      position: static !important;
     }
    }

    Hm, when I try that code, it shows two copies of the menu on the screen when I start scrolling down. It seems like the original menu is still there and a second menu appears as you scroll down.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Could you open up a new thread and link your site so that we can explore why: http://wordpress.org/support/theme/vantage#postform ? thx

    Sure, it’s still in progress, but it’s: http://hull1.com/bert

    The display:none was working fine, though.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Sorry I don’t want this thread to lose focus off aneketo (the original poster).

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to disable sticky menu at mobile browser’ is closed to new replies.
Skip to toolbar