Support » Plugin: Jetpack by WordPress.com » How to disable small top left share icon on images

  • Resolved patshi

    (@patshi)


    There is a “Save to Path” Icon on many of my images. How to disable this icon? I did not find any in the Jetpack Settings.

    my site: http:/ntown.at/blog/

    Thanks,
    Patrick.

    • This topic was modified 7 months, 2 weeks ago by  patshi.
    • This topic was modified 7 months, 2 weeks ago by  patshi.
    • This topic was modified 7 months, 2 weeks ago by  patshi.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That icon is not added by Jetpack. It’s not added by any of your plugins I think. I’d recommend that you check the list of extensions you’ve installed in your browser; one of those extensions is most likely adding the buttons to all images in your browser.

    That’s funny, because it’s shown the same time when I updated Jetpack 😉
    Have to look further.

    Thanks anyway,
    Patrick.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I wanted to send you some screenshots showing you how things looked like on my end, and then I saw the button when viewing a single post on your site! Sorry about that!

    It’s actually not a Path icon, it’s a Pinterest one. It’s added by the Pinterest library that’s included on your posts and used to display the Pinterest sharing button.

    There are 2 ways around this:

    • Switch to a non-official button style under Settings > Sharing in your dashboard. If you don’t use the official Pinterest button, Pinterest’s library won’t be added to your posts and the hover button won’t appear.
    • Keep the official buttons but force Pinterest not to display hover buttons, by adding the following snippet to a functionality plugin:
      add_filter( 'jetpack_pinit_over_button', '__return_false' );

    I would personally recommend the first solution, since it would also improve your site’s loading time: the less external libraries you load on your site, the faster it will be. If you switch to a non-official button style, you won’t load any external library to display the Facebook, Twitter, Google+, … buttons.

    I hope this helps.

    Christian Saborio

    (@christian-saborio)

    Does help, took a while to troubleshoot and find that Jetpack was the culprit. IMHO, this option show be easier to switch off/on and should be off by default.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘How to disable small top left share icon on images’ is closed to new replies.