Support » Fixing WordPress » How to disable post id skipping problem?

  • I’m using Asian language. I use post id as my permalink. So, it would be beautiful to see post number arranged continuously.

    I’m trying to disable post revision and autosave using WP CMS post control. Usually, the numbering is incremental. And sometimes, it skips one number. I tried to check that post number, it shows 404 error, without redirecting to previous or next post ( I saw the redirection works somewhere in older version).

    I can’t find any plugin more reliable than this. Should I edit wp-config.php manually to disable post revision? I’m running WordPress Network. I still want to leave revision feature in some child sites. And it is more efficient to configure using plugins instead

Viewing 4 replies - 1 through 4 (of 4 total)
  • You will probably not be able to do what you want because post IDs are used for other things than posts and revisions. Image attachments, pages, menu items and custom post types are all given post ID’s.

    Thanks for this info. I didn’t know that the database works this way. So, if I don’t touch any other post types, the posts’ ID will be arranged in incremental order correctly.

    vtxyzzy said

    Image attachments, pages, menu items and custom post types are all given post ID’s

    so you can never have img attachs or have any new menus either.

    Not practical; so why must the numbers be in seq. without skipping?

    Not only as 123milliseconds said, but you can never delete any of these things either.

    And, I don’t know what the autosave in TinyMCE does with the post, but I suspect that it also assigns an ID.

    You should find another answer to the problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘How to disable post id skipping problem?’ is closed to new replies.