Support » Fixing WordPress » how to disable or alter auto-update?

  • Resolved llizard


    I have been having a problem with the auto-update function malfunctioning (goes to a blank page and does NOT save anything). I believe it is due to my webhost’s restrictions on php which cannot be overridden.

    I searched these forums and came across the Modify AutoSave Interval section of the codex. I thought this might solve my problem – I could adjust the time between auto-saves to several minutes.

    define('AUTOSAVE_INTERVAL', 160 ); // seconds

    But this coding does NOT appear on WP2.7’s wp-config.php. Which file contains this coding?

    Thank you.

Viewing 10 replies - 1 through 10 (of 10 total)
  • no – you will need to add that code to wp-config.php then modify it the way you want

    Or you can use the WP-CMS Post Control plugin ( and turn it off completely. Just a thought – I hate the auto save feature and this worked great for me.


    1)Open your wp-admin/post.php file and wp-admin/post-new.php files.
    2)You will find this line of code there:


    3)Add // to the beginning of this code.

    The auto save option will be disabled for your existing and new posts.


    Shane G.

    Thank you, all. This is great. Disabling the auto-save is essentially what I wanted to do in the first place. Your fix has done the trick, Shane.

    I just discovered that it’s also necessary to place // before wp_enqueue_script('autosave'); in wp-admin/page.php and wp-admin/page-new.php

    That “trick” is not a good solution, because when a new version comes out, you will have to do it again. The pluing I suggested is what we use at work and what I use on all my personal blogs and requires no modification to the core code. Just my 2 cents…

    I agree that the plugin might well be the best solution. I will definitely take that under advisement. Thank you, GSB.

    Thanks I prefer the hack and would rather not install another plugin

    You can just put this in yoru wp-config
    to disable autosave and revisions on posts.

    define(‘WP_POST_REVISIONS’, false);

    but WP_PAGE_REVISIONS is not working and you have to follow the method in this thread

    Thank you, mohanarun. But I have installed the plugin; I ran into major problems when I tried to disable autosave manually on a wordpress hosted on a server that has several aspects of php disabled.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘how to disable or alter auto-update?’ is closed to new replies.