Support » Theme: Smartline Lite » How to disable magazine widgets from posts page

  • Resolved aussi

    (@aussi)



    We are using the ‘Magazine Homepage’ template with Smartline which works great for our home page. However, using this template automatically enables all the magazine widgets on our ‘Posts’ page, which we don’t want as this means a large chunk at the top of the posts page repeats what is on the home page.

    I have checked that the ‘Posts’ page is not secretly using the ‘Magazine Homepage’ template by disabling the posts page and checking its template. It is not.

    Any help would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Does anyone have any suggestions / solutions / workarounds for this problem? It is very annoying that the posts page is full of magazine home page widgets, forcing users to scroll a long way down before getting to the news.

    Theme Author ThemeZee

    (@themezee)

    Hi there,

    Thanks for using Smartline.

    You can use a Widget Visibility plugin to hide the widgets on the posts page.

    There are plenty of alternatives available:
    https://wordpress.org/plugins/widget-visibility-without-jetpack/
    https://wordpress.org/plugins/jetpack-widget-visibility/
    https://wordpress.org/plugins/widget-visibility/

    Best,
    Thomas

    aussi

    (@aussi)

    Thanks Thomas, that’s excellent. On researching this, I discovered that as I am using Jetpack, it has Widget Visibility features built in, but they were disabled because I’ve been using Jetpack for so long.

    For anyone else in this situation, you can enable the Jetpack “Widget Visibility” functionality via the module listing page here: <your-site-domain>/wp-admin/admin.php?page=jetpack_modules as well as a load of other useful Jetpack features.

    Theme Author ThemeZee

    (@themezee)

    Oh yeah, Jetpack has already built-in that module. Thanks for mentioning it 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.