Support » How-To and Troubleshooting » How to disable "leave a reply" section

How to disable "leave a reply" section

  • I’m new to this. And, I have looked at all the other, very similar, threads on this forum.
    I am getting the ‘Leave a Reply’ comments box showing at the bottom of each of my (static) pages.
    Previously, I have unchecked the ‘Allow people to post comments on new articles’ box in Discussion Settings. I have also deleted this line of code from single.php :<? php comments_template(); ?>. (It is not in page.php). These solutions worked -for a short time. But now the comments box has mysteriously returned.
    A friend seemed to think it might have something to do with one of my plug-ins (NextGen Gallery, Fast Secure Contact Form, Page Links To (which allows me to link to an external website)). But, I can’t see anything in their settings.
    My website is here: http://www.bellerophonantiques.co.uk

    Hope someone can help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Michael


    Forum Moderator

    disable the comments for the individual pages in the ‘discussion’ field below the page editor;
    if there is no ‘discussion’ field visible, click on the ‘screen options’ tab near the top right of the ‘edit page’ page, then tick the ‘discussion’ box – that should get the ‘discussion’ field below the page editor to show up.
    disable comments there.

    edit loop-page.php of your theme, and delete the comments_template() code there.

    twenty ten will be overwritten with the next upgrade of your wordpress version; consider http://codex.wordpress.org/Child_Themes

    Thank you so much.

    I also want to thank you,i was using a theme i though it had comments and leave a reply hardwired to the theme.

    but the solution was easy than looking at the page.php code.

    “screen option” is somehow hidden.. so i didnt had a clue it was there. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How to disable "leave a reply" section’ is closed to new replies.