WordPress.org

Forums

[resolved] How to disable fonts.googleapis.com? (6 posts)

  1. adrelanos
    Member
    Posted 1 year ago #

    On my blog (https://www.whonix.org/blog/) there is one fetch to fonts.googleapis.com. I already tried a few different theme. All were affected.

    My theme does not contain a line fonts.googleapis.com. However, wp-includes/script-loader.php includes:
    $open_sans_font_url = "//fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,300,400,600&subset=$subsets";

    How can I disable fonts.googleapis.com?

  2. C W
    Member
    Posted 1 year ago #

    That is the font used for the WordPress admin interface. And I don't know why you'd want to remove it.

  3. adrelanos
    Member
    Posted 1 year ago #

    Why depend on google for a thing as simple as a font? I don't like how google is handling privacy and don't see why they need to appear on every website. And preferred not to have them on my blog.

    How can I disable fonts.googleapis.com?

  4. C W
    Member
    Posted 1 year ago #

    There are many reasons for using Google Fonts, which were discussed during MP6 development. But if you personally don't want to use it, then install Disable Google Fonts.

  5. adrelanos
    Member
    Posted 1 year ago #

    That did the trick. Thank you.

  6. easeindesign
    Member
    Posted 1 year ago #

    I can give a good reason why google fonts is a bad idea: some countries are not Google-friendly. Just like trying to deal with Twitter and Facebook apis thrown carelessly all over the web; generally accomplishing nothing and usually called when not needed, google fonts is just another way to bog down the experience.

    I can see the benefits of clouding, but not as a starting point for a self-hosted project framework. I find it weird that there's a downloaded font-squirrel font "Genericons" in the theme, but still it seemed necessary to include a call to the google fonts as well.

    Anyway, thanks for the "Disable Google Fonts" plugin link Cyril, it also worked perfectly for me.

    I added this comment just to point out a reason. I've seen a few others trying to figure this problem out, including adrelanos, but it doesn't seem to be understood why people might not want it.

Topic Closed

This topic has been closed to new replies.

About this Topic