Support » Plugin: WooCommerce » How to disable css styles of WooCommerce

Viewing 9 replies - 1 through 9 (of 9 total)
  • Sorry to say, but it appears to be gone..

    2.1.0 – 10/02/2014
    Feature – Split frontend styles into separate appearance/layout stylesheets and removed the enable/disable option.

    Roy Ho


    While the user interface option is gone, you can still do this easily with filters. See

    Per James Koster’s blog, you can add this to your theme’s functions.php file and it will deactivate all WooCommerce’s styles:

    add_filter( 'woocommerce_enqueue_styles', '__return_false' );

    This filter is used here.

    Dangit Roy you stole my answer! 😀

    My functions.php is this:

    Could please modify it here for me to copy it? Thanks.

    // ensure EXT is defined
    if ( ! defined('EXT')) {
    	define('EXT', '.php');
    # See: wpgrade-config.php -> include-paths for additional theme specific
    # function and class includes
    // Theme specific settings
    // -----------------------
    // add theme support for post formats
    // child themes note: use the after_setup_theme hook with a callback
    $formats = array('quote', 'video', 'audio', 'gallery');
    add_theme_support('post-formats', $formats);
    add_theme_support( 'woocommerce' );
    // Initialize system core
    // ----------------------
    require_once 'wpgrade-core/bootstrap'.EXT;
    # Please perform any initialization via options in wpgrade-config and
    # calls in wpgrade-core/bootstrap. Required for testing.
    if ( ! isset($content_width)) {
    	$content_width = 960;

    I’m not comfortable editing your file for you as I’m not going to support anything that breaks. It’s one line of code to add.

    Ok Daniel, but could you say me where to add in this code? Any place is god? Sorry for the inconvenience.

    Ok ok, dont worry about that. Now I find the solution. Thanks very much and sorry for my poor english

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How to disable css styles of WooCommerce’ is closed to new replies.