WordPress.org

Support

Support » Plugins and Hacks » Comments Evolved for WordPress » [Resolved] How to disable commenting for specific pages

[Resolved] How to disable commenting for specific pages

Viewing 4 replies - 1 through 4 (of 4 total)
  • Okay, I can fix your problem. But I’m not sure have an other problem.

    1. You find

    /wp-content/plugins/gplus-comments/includes/lib/frontend.php

    2. Edit

    frontend.php

    function comments_evolved_template($file) {
    global $post, $comments;
    if ( !(is_singular() && (have_comments() || ‘open’ == $post->comment_status))) {
    return;
    }
    return COMMENTS_EVOLVED_TEMPLATES . ‘/container.php’;
    }

    => Add function “!is_page()

    function comments_evolved_template($file) {
    global $post, $comments;
    if (!(!is_page() && is_singular() && (have_comments() || ‘open’ == $post->comment_status))) {
    return;
    }
    return COMMENTS_EVOLVED_TEMPLATES . ‘/container.php’;
    }

    Thanks very much!! Exactly what I wanted.

    Hihi, no problem. I think interesting when I help you. I living Vietnam country, I speak English not well, could you skip for me.

    http://thongtincanbiet.vn/

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] How to disable commenting for specific pages’ is closed to new replies.
Skip to toolbar