Support » Plugin: Mihdan: Ajax Edit Comments » How to disable AEC links in RSS feeds?

  • Resolved sunamumaya

    (@sunamumaya)



    When seen by an editor, each item in the comment RSS feeds has AEC links (Edit More Options Moderate Spam Trash De-link Move E-mail Blacklist), which don’t work properly, by the way.

    How do I remove those completely from the RSS feed (I couldn’t find a setting)?

    I should mention I’m running it in a multisite environment.

    Thank you.

    http://wordpress.org/plugins/wp-ajax-edit-comments/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Ronald Huereca

    (@ronalfy)

    That’s very odd. AEC specifically checks for the is_feed conditional prior to loading. If it detects a feed, it shouldn’t load.

    I’m at WordCamp Europe this weekend, but I’ll double-check on my local multisite environment when I get back to Norway on Monday.

    Please see this screenshot illustrating the issue:

    http://i.imgur.com/OzJ0utQ.png

    Thanks for looking into this!

    Errata: links appear not only for editors, but for all visitors, IP-based, just as they would on the site itself, but without a time limit.

    Plugin Author Ronald Huereca

    (@ronalfy)

    I just pushed 5.0.30.0. I was able to duplicate the problem and fix it.

    Please let me know if you have any success. The way to test to see if it works is if you view a page, leave a test comment, and then browse to /feed/ of the post.

    Thanks for bringing this issue to my attention.

    Plugin Author Ronald Huereca

    (@ronalfy)

    Also, if this fix works for you, please consider leaving a rating/review 🙂

    You mean 5.0.35.0, I think 🙂

    I upgraded, then tested it, and it works well now, no AEC links in feed.

    Thanks for the fix!

    I’ll rate and review now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to disable AEC links in RSS feeds?’ is closed to new replies.