Support » Fixing WordPress » How to disable a plugin? Parse Error after upgrad new version – cannot open page

  • Resolved emdrgulin

    (@emdrgulin)


    I opened a topic under Ninja-Forms but also updated wordpress version just before that.
    ( with the same title )
    Parse error: syntax error, unexpected ‘[‘ in D:\Hosting\2867024\html\emdrkw\wp-content\plugins\ninja-forms\includes\Fields\ListImage.php on line 24

    This might be something else that I’m not sure, however
    Q?> is there a way to disable or remove a plugin completely?
    Q?> or only revert back that plugin to its previous version?

    I am not able to use my web page and I cannot use wp-admin page, either,
    which is urgent for me, I appreciate for any quick input/comment on this.

    Thanks a lot

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • JNashHawkins

    (@jnashhawkins)

    Rename that plugin’s directory. That will disable that plugin.

    Suman

    (@sumanm)

    I think you should first take backup of that plugin and then delete that plugin folder.
    Note:If you delete, make sure you first take backup of files and database.
    Note:Do not keep backedup plugin at the same path.

    Hope this helps:)

    emdrgulin

    (@emdrgulin)

    All,
    @sumanm / @dessiepkrok / @jnashhawkins
    I’ve never used wordpress by connecting to its servers directly.
    ( just a basic user to use via wp-admin gui and all from there )
    Maybe this is even more basic question to you however, please
    ? how could I connect to where? to my page’s hosting is on ?
    ? should I use the same credentials to login to that server ?
    Thanks again!

    mariayork

    (@mariayork)

    It is possible to deactivate plugins through the database.
    . Go to phpMyAdmin, go to the database and execute the request

    SELECT * FROM wp_options WHERE option_name = ‘active_plugins’;
    if the prefix is ​​not wp_ then change to the one that you have.

    2. Next, click edit on the result of the request … there should be something like

    a: x: {listing active plugins;}
    delete this line and save the results.
    Now all plugins are deactivated.
    If you need to disable only one plug-in, then edit the line accordingly deleting only it and adjusting the number of active plug-ins in the example above parameter “x”.

    JNashHawkins

    (@jnashhawkins)

    Just use your webhost’s control panel look for a file manager, FTP into the server, or navigate to that directory and rename the file.

    Thanks for all the replies and sorry for the delay in response.
    The issue was on PHP version which I changed on the server side, after disabling the plug-in by changing its name temporarily.
    It is PHP 5.6 & WordPress 5.3 at the moment.
    This has been resolved even though I’ve still been getting some different errors like
    “.. not a valid JSON response …” message after any update on wp-admin, at this state.
    But it is still updating OK.
    just FYI
    thanks,

    Resolved

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘How to disable a plugin? Parse Error after upgrad new version – cannot open page’ is closed to new replies.