Support » Plugins and Hacks » AgentPress Listings » [Resolved] How to delete invalid taxonomy

[Resolved] How to delete invalid taxonomy

  • Another user of the system created an invalid taxonomy named Property #

    The user didn’t noticed the note “no spaces, underscores, or special characters”

    So whenever you try to edit or delete the “property #” on the taxonomy admin page, it leads you to nowhere

    I tried to find and delete it on database but unfortunately I still can’t find where to delete it. You cannot delete it on wordpress it redirects you to nothing.

    How can I delete this?

    *Also, this is the reason the add media button is not working in the post below*


Viewing 9 replies - 1 through 9 (of 9 total)
  • I have tried deleting the plugin and it’s files, then reinstalling the plugin but the invalid taxonomy still exists! I don’t know if you can see it from the front end, but the URL is trypanama.com

    Plugin Author Ron Rennick


    Probably the only way you’ll be able to delete is by deleting the APL taxonomies option. Are you comfortable with doing that?

    If I have the steps to do that, I feel comfortable executing it. Can you give methe steps. I don’t find anything when googling “delete apl taxonomies”

    Is this something that can be done for a fee? Will the other valid taxonomies still be available? I only want to get ride of the invalid taxonomy and replace it with a valid one.

    Plugin Author Ron Rennick


    If I have the steps to do that, I feel comfortable executing it.

    Go to the wp_options table, search for agentpress_taxonomies. You should find one record. Delete it.


    One quick question Ron,

    Do you know how to get the listing taxonomy categories to work again?

    Now that I’ve deleted the agentpress_taxonomies from the wp_options table and added them all back through the Register Taxonomies page via the dashboard (with a valid taxonomy for property), only the Property taxonomy works on the listings now. I find it strange because when I added back the existing taxonomies, all their options showed up automatically without me having to re-enter them. I thought this was great, but when I went to the listings page from the dashboard, the entire right side of the page that lists the taxonomy categories are empty.

    When I go into a listing in edit mode, all the existing taxonomies are still selected. Even if I deselect and reselect the taxonomy option and update the listing, the taxonomy doesn’t show up on the listings page. Only the property number I add shows up.

    On my navigation menu, I used to have the statuses, For Rent and For Sale, as menu buttons. Now they don’t show either. When I went to edit the Navigation Menu, those two items show up as invalid.

    On the search widget I have to the right of the home page, it doesn’t separate out the properties. It doesn’t matter which status I select, all the listings display.

    Thanks in advance for any help you can provide!

    Also, all my listings are redirecting to 404 pages

    I have corrected all items above except the random listings not appearing in their appropriate categories.

    Example: Listing #0059 is ticked with the Sale taxonomy, but does not appear when searching “For Sale” properties or using the “For Sale” tab in the navigation bar.

    I will create a new Support thread for this, which can be read here:

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] How to delete invalid taxonomy’ is closed to new replies.