Support » Fixing WordPress » How to Define Media Upload Location

  • Resolved Alkorr

    (@alkorr)


    Hi, I just realized an option is missing in the latest version (5.4.2) of WP: I would like to change the default Media Upload location and it used to be in:

    Settings > Media > Uploading Files > Store uploads in this folder

    I want the upload directory to be outside wp-content: http://www.mydomain.com/images/

    Since the field is not showing anymore (I don’t know if it was done on purpose but now it’s way more difficult to set when you’re not WP-savvy) I have to add some code in the wp-config.php. So I checked on the WP Forums (here) and on the internet and I found several suggestions. I don’t code so I would like to check which one is the best because I don’t really get the difference between both:

    define( 'UPLOADS', 'images' );

    define( 'UPLOADS', ''.'images' );

    Or maybe there’s better than these ones? Thanks for your help! πŸ™‚

    • This topic was modified 2 years, 2 months ago by Jan Dembowski.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi, I just realized an option is missing in the latest version (5.4.2) of WP: I would like to change the default Media Upload location and it used to be in:

    Settings > Media > Uploading Files > Store uploads in this folder

    This was removed a long time ago, I believe before 5.0

    I want the upload directory to be outside wp-content: http://www.mydomain.com/images/

    Use:

    define( 'UPLOADS', 'images' );

    The “images” folder should exist and be writable.

    And when in doubt, consult the official documentation:

    Editing wp-config.php

    Thread Starter Alkorr

    (@alkorr)

    Thank you very much George for your answer and the link I’m gonna check right away! πŸ™‚

    Did George’s recommendation solve this issue for you? I’m facing same issue so I’ll appreciate you letting me know.

    Thanks
    John aka Configt

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How to Define Media Upload Location’ is closed to new replies.