WordPress.org

Support

Support » How-To and Troubleshooting » How to Configure RSS Widget

How to Configure RSS Widget

  • I am having trouble configuring the RSS widget. Even though I enter the RSS URL (http://dieterscookbook.com/wp-rss.php), it does not “save.” I save it and the RSS icon appears…however…it defaults back to the home page of my website. Should I just add the RSS on the sidebar manually? I’m not very “techie” so it could cause a problem but I’ll sure try if this doesn’t work.

Viewing 9 replies - 1 through 9 (of 9 total)
  • I think I found part of the problem. I guess I need http://dieterscookbook.com/feed but that page is not on my site. Is there a “template” or something that I can configure to add to my site?

    Try http://dieterscookbook.com/?feed=rss instead. The URL you gave would only work if you had permalinks on.

    That didn’t work either. How do I turn permalinks on?

    Actually, it looks to me like it’s working exactly as it should. Clicking the icon shows me your feed, clicking the title goes to your site, and each post title has a link. That’s exactly what the widget is supposed to do.

    As for permalinks, you’ve got them on, but they’re not working. You may have deleted your .htaccess, or your host might have mod_rewrite disabled. Details:

    http://codex.wordpress.org/Using_Permalinks

    Yes, I just noticed that if I click on the icon it works correctly. However, if I click on each post feed it goes to a page not found.

    Do you know how I can get only the icon?

    I really appreciate your help. You have no idea how much trouble a 60-year-old lady can get herself into!

    You’re getting the page not found for the reason I mentioned before–your permalinks aren’t working. Check out Using Permalinks thing and see if that helps. It’s lengthy but probably has what you need.

    As for getting only the icon, that’s a little tricky with the built-in RSS widget. But there are plugins like this that give you more control over how the RSS widget displays. That particular one assumes a bit of familiarity with HTML, though.

    On second though, what happens if you just enter a space in the RSS widget’s “title” box? Does that leave the title blank and show only the icon? Just a thought.

    Thanks…I got my permalinks working. The “space” only makes it put the name of the website instead of RSS. I’ll check out the plugin.

    Thank you! That works like a charm 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How to Configure RSS Widget’ is closed to new replies.