Support » Plugin: MultiSite System Cron » How to configure

  • Resolved choosegrowth

    (@choosegrowth)


    Reading through all the documentation I could not be 100% of my question.

    So once the plugin is installed and you change the settings in the multisite system cron menu, there is absolutely nothing left I have to do to have this function. Is that correct?

    Is there a way to test if it functioning? I have had it on for a bit now and haven’t seen the Execution Block like you have in your screenshot. Does that mean its not running?

    Just want to make sure I have this thing running as intended.

    Thanks!

    https://wordpress.org/plugins/multisite-system-cron/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Pau Iglesias

    (@pauiglesias)

    Hi choosegrowth, thanks to try our plugin.

    In addition to the plugin settings, you need to add a line to the Linux crontab with the command specified in the same plugin configuracion screen (the generated value of the field “Linux crontab line”).

    You can do this via accessing the server via SSH and editing the crontab manually (with “crontab -e” you can open a console editor).

    Another way, if you are using a web control panel, is to add this value in the scheduled taks sections, indicating a periodicity of one minute if possible.

    About the testing, the only way is to activate the PHP error_log debug in the plugin settings, but you also need access via SSH, or find a similar feature in your web panel, to inspect the PHP error log.

    I hope this helps.

    Regards,
    Pau

    Thread Starter choosegrowth

    (@choosegrowth)

    Ok that is making a little more sense to me. I have added the line the plugin generated to the proper place for cron jobs. I can see the cron job trying to run but it looks like it gets an error.

    Unable to find the number of public blogs for the site_id = 1.

    What can I do to get past this?

    Thanks!

    Plugin Author Pau Iglesias

    (@pauiglesias)

    It seems a strange behaviour. Do you have all your blogs in private mode? This plugin works with public blogs by default.

    Thread Starter choosegrowth

    (@choosegrowth)

    I did have everything under lock and key to limit access. I have since opened up those channels. I can now see the cron firing. Thanks!

    Hi Pau,

    I’m also getting the error message:

    Unable to find the number of public blogs for the site_id = 1.

    The blogs are set to discourage search engines, but otherwise they are public.

    Any ideas what the problem might be?

    Thanks,

    Chris

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘How to configure’ is closed to new replies.