Support » Plugin: WordPress Social Login » How to completely disable contact import? (FB problem)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Did you try line 937 in wsl.authentication.php

    // launch contact import if enabled
    //wsl_import_user_contacts( $provider, $adapter, $user_id );

    Comment it out see if that stops
    Also change scope on line 168 to match what you changed in Facebook.php

    // reset scope for if facebook
    if( strtolower( $provider ) == "facebook" ){
    $config["providers"][$provider]["scope"] = "email, user_about_me, user_birthday, user_hometown, user_website";
    $config["providers"][$provider]["display"] = "popup";
    }

    Thank you for your suggestions. I have tried it, but unfortunately nothing happened. It look for me like the friendlist request cannot be removed from FB at all.

    http://developers.facebook.com/docs/facebook-login/permissions/
    When someone connects with an app using Facebook Login, the app can access their public profile and friend list —the pieces of information that are visible to everyone.

    If there is a workaround, please tell me. The users here in germany are very cared about their privacy, so it could be a reason enought not to login on my site, if my plugin asks then for friends list….

    friendlistis also asked for on line 18 in Facebook.php Here So you can remove it there too otherwise I’m not sure why it keeps requesting it

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How to completely disable contact import? (FB problem)’ is closed to new replies.