Support » Plugin: WP Hide & Security Enhancer » How to cloak the url of the javascript exported by wp-includes

  • Based on the code of 4.9.8, in wp-includes/script-loader

    The $mejs_settings is output there to screen for Javascript, after turning on the WP Hide, all of the php generated page follow the rules except this.

    I found that the url of the called includes_url() by script-loader is already following the new url.
    When I closely trace the code, the data is being prepared in localize() in wp-includes/class.wp-includes.php. Right before JSON_encode is called, the URL is still ‘correct’.
    But afterward, it becomes ‘wp-includes’ again. I cannot find out why after calling JSON_encode, it return to the original path.

    So is there anyway to change this url based on the settings in the plugins already?

    Thanks a lot.

    • This topic was modified 11 months, 3 weeks ago by simongcc.
  • The topic ‘How to cloak the url of the javascript exported by wp-includes’ is closed to new replies.