Support » Fixing WordPress » how to change ‘siteurl’ function

  • Resolved syncbox


    I know this is weirdly unusual, but I have a need to have siteurl always resolve using the www. in the url

    Is there a simple way to make this change in the deeper function pages of WP?

    A specific client has a strange server setup where the public site is WP and hosted externally, but the domain is hosted internally… it’s a mess. That said, the site works just fine OUTSIDE of their offices. They can even get the site working inside their offices but trying to use one of the “site down for maintenance” plugins causes problems – all the login functions point to (‘siteurl’) which seems to always resolve without the www. in the address.

    For them to see the site, they HAVE TO HAVE it resolve WITH www. in the address.

    OK, you WP gurus… possible? if yes, how (without somehow having to change a million things)


Viewing 1 replies (of 1 total)
  • OK, nevermind… as typical, as soon as I asked for help, I figured it out myself, but hey, that’s ok, too!

    what I did was to look through the db for anything using (not really, but you get my drift) and changed it to

    It was only in two locations in the options table and seems to have fixed my issue. The maintenance mode plugin seems to work – it both hides the site (except for admin users) and still allows the admin to VIEW the site.

Viewing 1 replies (of 1 total)
  • The topic ‘how to change ‘siteurl’ function’ is closed to new replies.