Support » Plugin: Web Stories » How to change main URL “Stories”

  • Resolved tslimnos

    (@tslimnos)


    Hello there,
    I have this page and I have already a page that has the name “stories”
    Is there any way as soon as I enable the WebStories Plugin to change the URL (permalink) to something else?
    Because after I enable it now I cannot save any stories and I am guessing that because I have already this name on a page I cannot work with your plugin.
    Is there any way to fix this?
    I am also using Yoast Premium.
    Thanks in advance.
    Kind regards,
    Thanasis

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    Hi Thanasis,

    Thanks for getting in touch!

    We’ll be happy to check on this. We use /web-stories/ as the default base for stories as opposed to /stories/. To confirm, are you able to edit each story in the editor and click “Update” without making any changes?

    To your question about changing the URL, there’s currently no built-in way to change the Web Stories URL structure, as this could easily result in lots of conflicts.

    That said, Web Stories are just like any other custom post type on a WordPress site, so there are some broader possibilities you can explore. You could try an approach previously explored at https://wordpress.org/support/topic/how-to-create-a-custom-post-type-without-extra-slug/, or a plugin like https://wordpress.org/plugins/permalinks-customizer/ to achieve this.

    That said, we haven’t tested either, so please be cautious of doing that on your live website to avoid breaking your site.

    Thread Starter tslimnos

    (@tslimnos)

    Hi Bethany,

    Sorry for my delay in this answer.

    To confirm, are you able to edit each story in the editor and click “Update” without making any changes?

    Yes, when I enable your plugin, I can edit and create Web-Stories but they are not saved.
    The reason I asked for the URL is that I think this was the issue.
    If your URL is different and not conflict with mine /stories/ then it must be something else…

    That said, we haven’t tested either, so please be cautious of doing that on your live website to avoid breaking your site.

    I am not going to test anything because our site is live and I do not want something bad to happen.
    How can I check for conflicts with other plugins? Do you have already some known issues?
    Thanks again for your reply and help on this.
    Kind regards,
    Thanasis

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    Hi Thanasis,

    Yes, when I enable your plugin, I can edit and create Web-Stories but they are not saved.
    The reason I asked for the URL is that I think this was the issue.
    If your URL is different and not conflict with mine /stories/ then it must be something else…

    Yes, agreed that it sounds like this is not related to the URLs, so let’s try to figure out what’s going on!

    To help us troubleshoot, can you please share the following info?

    1. A screenshot of any browser console errors from when you try to save a story. The forums do not support screenshot uploads, so you can share one via a link generated by Imgur or JumpShare.
    2. Can you confirm that your WordPress Address URL and Site Address URL are the same in Settings > General in WordPress?
    3. Your Site Health information privately via this form.

    Thank you!

    Plugin Support Luckyna San

    (@luckynasan)

    @tslimnos Hi there, have you had a chance to gather/submit the above details? Please let us know and we can troubleshoot further. Thanks!

    Thread Starter tslimnos

    (@tslimnos)

    Hello again and sorry for the delay!

    I have enabled web stories now on my website and as you can see when you visit this page you will see a 404 error.

    https://vogdanidis.com/web-stories/

    Here is a screenshot from my browser in one saved story.

    I will send you also using the form above my Site Health.

    Thanks for the support on this,

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    Thanks, @tslimnos! Yes, please do send over the Site Health info, and we’d be happy to take a look.

    Also, the forums do not support screenshot uploads, so you can share one via a link generated by Imgur or JumpShare.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @tslimnos Thanks for sending over the Site Health info.

    I’m not able to replicate any issues so far on my end so it would be really helpful for me to see exactly what you’re seeing.

    For just a few minutes, can you reactivate the plugin and take a screen video of what you see on the /web-stories/ page, /stories/ page, and in the back-end for Web Stories when you have the plugin active? You can take a video of your screen and share it via link using the free Loom app. I know that this temporarily “breaks” your /stories/ page but this would help us tremendously with troubleshooting, and you can turn the plugin back off after recording the video.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @tslimnos Checking back in here. Have you had a chance to take a video of what you’re seeing?

    One thing you may want to try if you haven’t already is re-saving your site’s permalinks by going to Settings > Permalinks and then click Save Changes to refresh. Can you let me know if that fixes the issue?

    Thanks!

    Plugin Support Luckyna San

    (@luckynasan)

    @tslimnos We are going to mark your topic as resolved as we haven’t received a response. Please feel free to open a new support topic if you continue to experience any issues. Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How to change main URL “Stories”’ is closed to new replies.