WordPress.org

Support

Support » How-To and Troubleshooting » How to change default "fallback to index.php" option?

How to change default "fallback to index.php" option?

  • Hi there, thank you for your time!

    Question:
    Does anyone in here know how to make WordPress NOT direct a mistyped URL-address back to index.php? Let’s say I manually type in a URL that does not exist on the server (or in the WordPress database), the WP then automaticly sends me back to index.php – making it failsafe, right? Well, I don’t want that, I rather have a 404 error message or something …

    … and here’s why:
    I have several WordPress installations (individual installations, not multisite) in subfolders on the server, and when I then link or type in the exact URL to one of those subfolders/sites – the Main Site WordPress automaticly steps in and re-directs me to the Main Site (instead of letting me through to the subfolder site). If I then manually type in the URL again, Main Site WP lets me trough (as I want it too) – but who knows about having to type the URL twice? I have already lost the visitor on the 1st try!

    So, I’ll be happy for any help or reply to this annoying issue …

    Best regards,
    Henrik, SWEDEN

  • The topic ‘How to change default "fallback to index.php" option?’ is closed to new replies.