Booking Calendar
[resolved] How To Center Booking Calendar in Post Field (5 posts)

  1. SW22958
    Posted 3 years ago #

    I would like to have the Booking Calendar centered in the post area for my Word Press page - by default it appears to be left-justified. What's the best way to do this? I've tried some of the more obvious things in the stylesheet without any success; obviously I'm looking in the wrong area.

    Thanks in advance.


  2. wpdevelop
    Plugin Author

    Posted 3 years ago #

    you can try to insert the booking shortcode into these HTML elements: <center>

    So you will have the shortcode like this:

    If its will not help, so its mean that its require some CSS customization at your page. In this case please send the link to the page with booking form, so then we will check and try to help.

  3. SW22958
    Posted 3 years ago #

    Thanks for the rapid response! I do appreciate it ...

    Using the <center> approach doesn't work. Before I contacted you I had partial success by putting the [booking nummonths=3] shortcode in a table construct as follows :

    <table width="100%">
    <div align="center">[booking nummonths=3]</div>

    Oddly, this causes the calendars to be properly centered, but the calendar legend and the response form remain locked to the left-hand margin. This makes me think that maybe there's some CSS or other code in your plugin that's overriding WordPress itself and forcing those elements to the left margin (at least that's what happens in the FireFox 14 rendering of the page).

    The page URL is

    Any suggestions?

    Thanks in advance ...

  4. wpdevelop
    Plugin Author

    Posted 3 years ago #

    please open this file:
    at line 159
    and make this modifications:

    .block_hints {
      border: medium none;
      clear: both;
      font-size: 11px;
      height: 30px;
      margin: 0 auto !important;
      width: 280px !important;

    then at line 63 make this modifications:

    .booking_form_div {
      text-align: left;
      margin: 0 auto;
      width: 281px;
  5. SW22958
    Posted 3 years ago #


    I appreciate the rapid response and the great support!

    I've made the suggested changes and everything looks great. The only issue was that the legend was wrapping to two lines (perhaps a function of my browser's default font size) so I increased the width: parameter for the line 159 mod to '325' and the legend no longer wraps.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Booking Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic