Support » Plugin: iThemes Security (formerly Better WP Security) » How to ban specific user agent text?

  • I’m seeing lots of brute force attack attempts that display the following user agent string:

    Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0

    The truly unique part of that user agent string is the “rv:19.0” part. Everything else in the user agent string is fairly commonly displayed on my site by legitimate site visitors.

    So, I’d love to ban any user agent containing the text “rv:19.0”. Is there a way to do that?

    When I place the entire string into the Ban User Agents, it then locks me out of my own site, and I believe this is because my own user agent also identifies itself as Windows NT 6.1 and Mozilla/5.0 (but not rf:19.0).

    When I place just “rv:19.0” (without quotation marks) into the Ban User Agent box, it does NOT ban user agents containing that text.

    Any ideas?

    http://wordpress.org/extend/plugins/better-wp-security/

  • The topic ‘How to ban specific user agent text?’ is closed to new replies.