Support » Theme: Nisarg » How to avoid all caps in Nisarg tagline?

  • alasani

    (@alasani)


    Hi,

    In order to get a bilingual website, I am currently translating my content from English into Dutch. I am using the Nisarg theme.

    In the tagline, all words start with upper case, eventhough I type lower case. This is fine in English. In Dutch, however, we use upper case for the first word in a header only, while the other words need lower case. How to stop each word from automatically converting to upper case?

    I would much appreciate your help!
    Audrey

Viewing 14 replies - 1 through 14 (of 14 total)
  • Theme Author Falguni

    (@falgunihdesai)

    HI Audrey,

    To avoid caps in Nisarg tagline, you can add following CSS code in Customizer > Addition Css section and then save it.

    .site-description {
    text-transform: lowercase;
    }

    Hope this will solve your issue.

    Falguni

    Hi Fulgani,

    Thanks very much for your advice!

    For my understanding: will this CSS code generate lowercase only? That is not what I need either. I need the tagline to start with uppercase, and the next words in lowercase – basically, I need the tagline to follow what I type. Please let me know!

    Kind regards,
    Audrey

    Hi Ausdrey,

    you can you use the value “none” instead of “lowercase”.

    See the description here:
    https://www.w3schools.com/cssref/pr_text_text-transform.asp

    Regards

    HP

    • This reply was modified 5 months, 3 weeks ago by  peterjohann.

    Thanks very much for your addition, HP!

    I have tried Falguni’s solution and since that did not work, I replaced “lowercase” by “none”, as per HP’s advice. The tagline does not respond to either codes.

    (I made a screenshot of the situation, however, there does not seem to be an option for attachments?)

    I am using Nisarg as a Child Theme. Could that explain the non-responsiveness? Should I add the CSS code to the mother? Or, anything else?

    Thanks for helping out!
    Audrey

    Hm –

    what happens if you try this CSS-Code (.site-title instead of .site-description)?

    .site-title {
    text-transform: none;
    }

    Regards

    HP

    Same thing, HP. No response…

    What else to do?

    It is getting a little tedious. I could just leave it (don’t really want to), but am also wondering: why does it not work?

    Thanks for your efforts!
    Audrey

    “Should I add the CSS code to the mother?”

    Did you try that?

    Theme Author Falguni

    (@falgunihdesai)

    Hi Audrey,

    As per your requirement stated above- ” You need the tagline to start with uppercase, and the next words in lowercase – “,

    So you add following css to the Advanced css section in customizer.

    site-description {
    text-transform: none;
    }

    And after adding this in your tagline, type the first word starting with Uppercase and then other words in lowercase(the way you want).

    Default setting for tagline is Capitalize. So all words starts with Capital letter. But if you will set it to none, the tagline will appear the way you will type.

    Falguni

    I changed my tagline in this theme using your code and it works perfectly.
    Thanks!

    Thanks for responding, everyone!

    I have repeated the procedure, as per Falguni’s instructions. (I think you mean: the Additional CSS section?) No reponse.

    Then, I added Fulgani’s additional css code to the Child’s CSS. No response.

    Finally, I tried changing Capitalize into None in the Nisarg CSS. No response.

    Is there anything left to try? Apparently, it worked for Goldfishflake… What is the difference? Perhaps my child theme? Or my subdomain?

    Thanks,
    Audrey

    Theme Author Falguni

    (@falgunihdesai)

    hey Audrey,

    Can you share your website link ? So that i can have a look at css code.

    Falguni

    I did notice the most recent css above doesn’t include the . before site-description?
    Maybe that makes a difference? Missed that before, but was following up on some css in my theme and noticed it.
    Just a thought but you could try it with !important added?

    .site-description {
    text-transform: none !important;
    }

    Another thought I just had is did you check in the Site Identity of Customize and make sure you didn’t type it as Uppercase?

    This is exactly it, Goldfishflake!

    The second I inserted the dot, the lower cap that I needed popped up.

    Thank you all very much for your efforts, and special thanks to Goldfishflake for solving the puzzle!

    Oh, and you are all welcome to check out my website. It is open for comments!
    http://www.surinametraveltips.com

    Ciao,
    Audrey

    Glad to be of help.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.