Support » Plugin: Podcast Player - Your Podcasting Companion » How to auto update podcasts

  • Hi,

    Is there a way for podcast player to update the podcasts on the website without logging in to manually update the plugin?

    Despite setting the update interval to 2 hours, it will still not work.

    Thank you

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    Thanks for using podcast player on your website.

    Normally podcast player should update automatically without any issue. However, please provide the URL of your podcast and website page. I will check and try to identify the issue.

    Thanks,

    Thread Starter mibusiness

    (@mibusiness)

    https://compliancedepartment.co.uk/podcast/

    It only updated once I manually updated it.

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    I checked your podcast feed (https://anchor.fm/s/e5fdc628/podcast/rss) and there are three episodes in the feed. The player also displays three episodes.

    Please check once you release any new episode. If it does not get updated within the set time (12 hours by default), please inform me.

    Thanks,

    Thread Starter mibusiness

    (@mibusiness)

    Hi, the podcast did update automatically. We changed the updated time for 2 hours but it was updated in 12 hours instead of 2.

    With the default 12 hours, what 12 hours is it? Is it at a certain time of the day or 12 hours after the podcast is uploaded onto spotify?

    Hi there,

    The 12 hours (720 minutes) in the default setting. It means 12 hours from the last update.

    It should follow your 2 hours setting. Can you confirm that you have changed 720 to 120 in podcast update interval setting in the WordPress Dashboard > Podcast Player > Settings.

    Thanks,

    Thread Starter mibusiness

    (@mibusiness)

    I can confirm that it has been changed to 120 from 720.

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    Did the podcast still take 12 hours to update? If yes, can you please inform if you are using any caching plugin. It might be possible that the caching plugin is not letting the page update?

    Thanks,

    Thread Starter mibusiness

    (@mibusiness)

    Hi,

    I uploaded a podcast on Friday. I checked on monday and it still did not update at all so I had to do it manually

    Thread Starter mibusiness

    (@mibusiness)

    We do use LiteSpeed Cache as a plugin on our site

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    Thanks for your inputs. Could you help me in resolving this issue. I need to know,
    1. Once you update the podcast (by clicking on the refresh icon on podcast player page). Does it immediately update on the front-end.

    2. Is it possible to prevent caching on a specific page where podcast player is displayed? Is yes, can we try that?

    I will analyze the issue and try to resolve it in next update.

    Thanks,

    Thread Starter mibusiness

    (@mibusiness)

    Hi,

    It does refresh when I click on the manual update straight away on the front-end. We have also disabled caching on the specific page where the podcast player is but this is still not working for us.

    Thread Starter mibusiness

    (@mibusiness)

    Is there any news yet? The podcasts are still not updating on the website.

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    I did tried to replicate the issue by installing lite speed cache on my test server. However, I could not reproduce the issue (Podcast player automatically updates after specified time interval).

    Let’s try to enable the “Minimize unintentional exposure of podcast data” setting from WordPress Dashboard > Podcast Player > Settings. Let’s see if that updates the podcast data.

    If not, please contact me at contact@easypodcastpro.com. I might need more information or temporary backend access to identify the exact issue. However, I hope the above setting might work.

    Inform me for more help or explanation on this.

    Thanks,

    Thread Starter mibusiness

    (@mibusiness)

    Hi, I believe that this has been done, and there is still no difference. Podcasts are still not updating automatically.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.