Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » How to add text on thumbnail page??

  • I want to figure out how to add text (paragraphs) to the thumbnail page on each gallery. In other words, after I click on a gallery and it opens up all the thumbnails, I want to have text describing the work either above or below the thumbnails.

    This is similar to the template=extend, but I don’t want the text next to a single thumbnail.

    Is there a way to maybe have each gallery open on a separate page, so essentially I’m embedding the shortcode for the gallery on a page instead of the album? But linked off the album?

    Hope this makes sense. I’m pretty sure the solution would involve custom programming the code.


Viewing 15 replies - 1 through 15 (of 15 total)
  • Adding paragraphs:
    Albums and galleries are basically WordPress pages so you can edit the galley page to add text above or below the shortcode your using.

    Gallery open on a separate page:
    Thats how NextGEN works. If you have your galleries in an album and put the ablum shortocde on a page/post then you’ll see gallery thumbnails. Clicking on a gallery thumbnail will take you to the gallery page with image thumbnails on it.

    Thanks Toshi.
    Still very confused about what to do here…

    Do you have a link to your wesbite? It may be easier to follow if we use real names from your website.

    yes. thanks.

    go to “projects” (that page is displaying my album.)

    when i click on any of those individual galleries, “eyebrow dormer” for example, i want to add text to the page that opens with all the thumbnails for eyebrow dormer.

    thank you!

    Your sites totally different to mine. I had a quick try to replicate a gallery path like /project-gallery/nggallery/project-photos/stanmeyer-porch/ but couldn’t.

    All my galleries are on a PHYSICAL wordpress page,so if I go to the Pages tab is see pages with the names of my galleries. So my gallery path for me looks like /gallery/woodblock-prints/osamu-sugiyama/.

    Given your gallery path includes nggallery I think NextGEN is generating that gallery page for you.

    Go to Gallery then Manage Gallery and select gallery stanmeyer-porch. What do you see in the “Page Link to” and “Path: fields?

    thanks again man.

    stanmeyer porch
    page link to: not linked
    path: wp-content/gallery/stanmeyer-porch_1

    Because you have “page link to: not linked” the NextGEN plugin is generating the gallery page for you and thats a page you cannot edit.

    To add text to a galley page it must be a ‘real’ page ie. it must be in the list of pages that appear under the WordPress Pages tab.

    I create my galleries on ‘real’ pages by selecting a suitable parent page from the “Create new page” dropdown list and clicking on “Add Page”. That instructs NextGEN to create a child page under the parent page with the name of my gallery and writes onto the page the correct shortcode for that gallery.

    The new gallery page will then appear under the WordPress Pages tab which means I can now edit it like any other WordPress page to add text, banners etc.

    !!!Presumably your site is live so you should exercise caution trying this out!!!

    Before changing any existing galleries maybe try creating a test gallery to get a feel for how it works. It looks like project-gallery is a real page (?), if so, maybe try creating a new gallery ‘test’ following the above method and copy some photos from another gallery into it. Then edit the Page ‘test’ to add some text – as thats your goal. Add ‘test’ gallery (drag/drop in Album tab) to the ablum that’s on the project-galley page. Then check ‘test’ appears on the project-galley page and when the ‘test’ gallery thumbnail is clicked it shows the files you copied in and the text you added.

    you are the man. this is what i’ve been trying to do and it’s so easy!
    however, how do i prevent all the separate gallery pages from being displayed in my menu?

    I still want to keep the same format. Is this possible?

    Thanks again man.
    I think i’m pretty close. this will make all the difference to my site.

    go to my site again and check out the “test” link. that works fine.
    but i don’t want to see “test” on the menu. i want that page to come up when i select the gallery from the album page…

    how do i prevent all the separate gallery pages from being displayed in my menu? I’m not sure what you mean by ‘menu’.

    I still want to keep the same format. Is this possible? The path name to the galleries would be different but it would look the same.

    check out the “test” link. that works fine. The path looks odd, it’s the same formsat as your other galleries. Is there a page named test under the Pages tab?

    i don’t want to see “test” on the menu. I’m not sure what you mean by ‘menu’.

    Tis late so might not be able to reply again today (well, night for me as its nearly 3am).

    by menu i mean all the links in my sidebar – the main navigation area of my site: home, projects, videos, machine, contact.
    if i start creating about 40 separate pages for all my galleries, i don’t want to see a list of those galleries on the left.

    yes, there is a page named “test.”

    i wonder about instead of an album make a gallery with one image from each album, that can then link to each of the separate pages?
    hope you understand what i’m trying to do.

    thanks man. i’ll keep “test” up for awhile longer.

    good night

    Ah, the actual navigation menu. Removing ‘test’ from the menu depends how your menu is created/placed in the sidebar – the navigation/menu widget usually has an include/exclude option. Or more commonly now, its in the wordpress menu in Appearance, Menus.

    First though go to Pages and Quick Edit ‘test’ to make it a subpage of project-gallery then check the website project-gallery page and hover over ‘test’ its path should now be /project-gallery/test/ – you don’t really want the /nggallery/ structure.

    i did this. the path was /project-gallery/test/, but the format is not at all how i want this all displayed.
    please help.
    any chance i could email/gmail chat directly?

    or, would you be interested in helping me for hire? i could give you the admin login and you could poke around in there.

    thanks man.

    Create a new user and send me the details. I won’t change anything, I’ll just see if I can spot anything interesting. I’m just a NextGEN user so I can’t give any guarantees I can resolve this.

    Create the user with the lowest level of access permissions where I can still look at the NextGEN plgun settings and at the WordPress pages.

    Email the access details to me using the contact page at

    I suggest you backup the db before you give me the access. That way if you wish, you can restore the db after I’ve looked around.



    If you havent fixed this yet i think it is very easy.

    Create page for your gallery thumbnails.
    Then link your gallery in gallery settings to the newly created page. (pull down in top right corner of gallery settings).
    Do this with all of your galleries that you want in the album.
    Then when you click on the gallery in your Album page it will open the linked page instead of the Album extended page.

    So then you are able to write as much as you like on the gallery page.

    Problem solved easily!!!

    See my Album page here that links directly to thumbnail pages with text.


    Hope this helps

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘How to add text on thumbnail page??’ is closed to new replies.