Support » Alpha/Beta/RC » How to Add Post Thumbnail in WP 2.9 Beta 1

Viewing 15 replies - 1 through 15 (of 15 total)
  • Same here. Can’t find the thumbnail panel.

    I have also checked in the screen options and it is not in there un-ticked either. Anyone any ideas?

    Same here. it simply had been disappeared after upgrading with wordPress beta tester.

    The 2.9 beta tries to be smart about themes, and will only enable the post thumbnails if the theme, in its functions.php, calls:

    add_theme_support('post-thumbnails');

    Of course you can manually add that for now, if you have something like the auto navigation plugin which is 2.9-ready and will use them for displaying sub-pages, even if your theme does not support them.

    Thanks for that. So what exactly do I need to add to my functions.php. Would the following work:

    <?php add_theme_support('post-thumbnails'); ?>

    Seems strange that it doesn’t just work out of the box. I thought that was the whole point?

    I can now confirm that putting the above code into the functions.php does activate the panel. Thanks wlindley!

    Thanks wlindley.

    I added it, and it shows on the right, set thumbnail, but I click on it, it tells me to pick the image, and when I click edit image, to make only part of it thumbnail, the save button is blue, and I don’t think its saving it. Any suggestions?

    AlternativePhotography

    (@alternativephotography)

    @astriker There is a link… not a button that says “Use as thumbnail”. At least in my panel, this adds it as a thumbnail.

    For those like me who are not too hot on php, it’s:
    add_theme_support('post-thumbnails');
    and not:
    <?php add_theme_support('post-thumbnails'); ?>
    that works for me when added to functions.php

    Mark

    (@codeispoetry)

    Helpful post on post thumbnails in WP2.9 here:
    New in WordPress 2.9: Post Thumbnail Images

    I had been wondering why is the thumbnail option not showing in the admin panel of my blog. The mystery is resolved now. Thank you all..

    I tried the suggestion by alternative and I have lost my site. Its all in white. I have reuploaded the original functions.php and nothing.

    Any ideas?

    thanks

    Uffff. Same problem here. I’d really appreciate if someone could give me a hint or post a link with an error fix. I think that’s a bug or something.

    That blank screen means you have a PHP error, but your site isn’t set up to show you the contents of the error, so you get a blank page.

    If you create a new file with the name .htaccess in the root of your site and put the following into it (or, if you already have a .htaccess, add this line to it):

    php_flag display_errors on

    and then revisit the page, you should see the error output. It’ll probably be something simple, but if you don’t understand, paste the error and the lines it complains about here and someone will help I’m sure 🙂

    I read several explanations for how to get the Post Thumbnail function to show up in my Post Editor (WordPress version 3.0.1), and none of them worked until I created a functions.php file in my theme with the following code, as recommended by Matt Brett at http://mattbrett.com/workshop/2010/wordpress-post-thumbnails-revisited/

    <?php
    if (function_exists(‘add_theme_support’)) {
    add_theme_support(‘post-thumbnails’);
    }
    ?>

    Thanks to Matt.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘How to Add Post Thumbnail in WP 2.9 Beta 1’ is closed to new replies.