Support » Plugin: Simple Lightbox » How to add Lightbox to Image Widget

  • Resolved ananddevops

    (@ananddevops)


    Hello,

    I am using the simple WordPress image widget. On click I would like to open my image in a Lightbox. I have installed the Simple Lightbox plugin and enabled it for widgets and saved the settings.

    Now when I go to the editor, in the image widget, I don’t see where the image can be opened in a light box. How to enable the same?

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • It seems the Lightbox feature works only on image links from the Media Library and not for external custom URLs

    Plugin Author Archetyped

    (@archetyped)

    Hi, SLB supports any valid link in widgets, including external URLs.

    If you have ensured that your widget contains a valid image link and you are still experiencing an issue, please provide a link to a page that exhibits the issue you are experiencing as well as a link to the specific widget plugin you are using to add the image link, and I would be glad to take a closer look.

    ananddevops

    (@ananddevops)

    @archetyped I am trying to open images from my photostream on Flickr. This is a public image.

    See here in – screenshot, that I have added the same link as the url. SLB is working fine for a media library image, but not these ones. So I tried same image from Imgur – https://imgur.com/iX8Z8yU and it doesn’t work either.

    They basically open in the same tab or a new(if chosen so) tab. but not in a lightbox.

    Thanks

    Plugin Author Archetyped

    (@archetyped)

    Hi, SLB works natively with links to image files, not links to HTML pages that display an image (which is what the links you provided are). When a link to the actual image file is added, SLB will display it in the lightbox.

    @archetyped Makes sense. Let me try the same for both Flickr and Imgur and will share the results.

    Thank You

    @archetyped I checked. True, for both cases.

    Thank You

    Plugin Author Archetyped

    (@archetyped)

    Awesome, glad to hear your issue was resolved 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.