Support » Plugin: Email Address Encoder » How to activate translation

  • Resolved bios4

    (@bios4)


    Hi,

    I can’t get the translation (de_DE) of the plugin to work.

    I tried to store the *mo/*.po files in <plugin-root\languages> as well as in <wp-content\languages>. None of these worked.

    Also this applies to both environments – locally (XAMPP on Windows) as well as online (Linux-based environment of my hoster).

    I’m using Loco Translate to check/update translations, and it tells me that everything is set up correcty, also showing 100% translation status.

    What am I missing?
    What am I doing wrong?

    • This topic was modified 6 months, 3 weeks ago by bios4.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Normally, translations are proposed here https://translate.wordpress.org/locale/de/default/wp-plugins/email-address-encoder/

    After you finished translations (for the current version, or for the development trunk version), inform one of the editors stated there.

    Please note: I already translated the trunk versions for DE, which are still in the suggested state.

    As soon as 90% of the translations are accepted, the translation is automatically activated, and will be applied to installations on next auto update.

    • This reply was modified 6 months, 3 weeks ago by toxicum.

    You can inform plugin translation editors for DE in the “DE – WordPress” Slack #polyglots channel. See https://de.wordpress.org/slack/

    Thread Starter bios4

    (@bios4)

    Hi @toxicum,

    thanks for your replies!

    I know how to contribute to translations (did that already for some plugins).

    But right now I don’t want to contribute to translations or add/change/update anything, but just want to make translations work at all for the plugin in my environments!

    As soon as 90% of the translations are accepted, the translation is automatically activated, and will be applied to installations on next auto update.

    So does that mean as long as the development team does not “allow for” translations, I can’t display the plugin pages in my desired language?

    I already have po/mo files created (with Loco translate) by myself and want to use them!

    The plugin text domain says it should be in the folder “/languages”, but this does not work. And also moving the po/mo to the “default plugin translation folder” in wp-content\languages\plugins has no effect.

    So I wonder where I have to put them to make the translations work in that case – if it is possible at all…

    Thanks,
    Mike

    Played around a bit.
    When I add the de_DE .po file to the languages/plugins dir, it works here.

    (wp-content/languages/plugins/email-address-encoder-de_DE.po)

    This is the same dir where automatic translation updates are normally stored in.

    • This reply was modified 6 months, 3 weeks ago by toxicum.
    • This reply was modified 6 months, 3 weeks ago by toxicum.
    Thread Starter bios4

    (@bios4)

    Thanks for the update, @toxicum.

    Right now I downloaded the po/mo files once more from the official page (https://translate.wordpress.org/projects/wp-plugins/email-address-encoder/stable/de/default/) and put them in the folder in wp-content again.

    And it works now (for whatever reason) without issues!

    Thanks for your hints!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘How to activate translation’ is closed to new replies.