Support » Networking WordPress » how the images retain in multisite

  • Resolved Wayne Ng

    (@wayne-ng)


    Hi,

    I can create the multisite successfully, say Blog A(Eng) and Blog A(Chi), but why the background image from Blog A(Chi) and the menu button is missing and while just a menu image is retained.

    also, if i try to upload the background image for the Blog A(Chi), it says “Unable to create directory wp-content/uploads/sites/2/2013/04. Is its parent directory writable by the server?”
    But I am pretty sure that I have no such folder of “sites/2/2013/04” in the Blog A(Eng). And I am uploading the files to “uploads/2013/04” rather than “sites/2/2013/04” in Blog A(Eng).

    Even though i manually created a folder as “sites/2/2013/04” and set the permission to “777”, it still can not upload the image.

    Anyone please advise on my problem, i just want to display the same background images and menu button in Blog A(Chi) version…

Viewing 10 replies - 1 through 10 (of 10 total)
  • i found some related post by the member said “You’d have to edit the CSS manually (make a child theme and have the image included in it would do).”

    I try to do so but I can not find the “edit” at “Appearance”>”Edit” after I created the multisite on both Blog A(Eng) and Blog A(Chi) thus i can not edit the css file of Blog A(Chi)… please help…

    i found some related post by the member said “You’d have to edit the CSS manually (make a child theme and have the image included in it would do).”

    I try to do so but I can not find the “edit” at “Appearance”>”Edit” after I created the multisite on both Blog A(Eng) and Blog A(Chi) thus i can not edit the css file of Blog A(Chi)… please help…

    also, if i try to upload the background image for the Blog A(Chi), it says “Unable to create directory wp-content/uploads/sites/2/2013/04. Is its parent directory writable by the server?”

    Your primary blog (site #1) uses wp-content/uploads/YYYY/ for images.

    ALL of your subsites use wp-content/uploads/sites/

    If that folder doesn’t exist, or it’s not writeable, you get that error.

    Can you upload on your main site?

    Thanks Ipstenu,
    I really didn’t not find any folder at wp-content/uploads/sites/…
    I am afraid I got the error….so how to fix it?

    My main site is as follow:
    http://www.jmadesigncompetition.org/

    Thanks

    Okay then you have to MAKE the folder 🙂

    Can you upload images on your main site?

    Do Pretty Permalinks work on your main site?

    ok and i am quite ambiguous on using the wordpress please clarify if i am wrong.

    I would manually create the folder named as “sites” under wp-content/uploads, is it “sites” is correct or the exactly name of the site?
    any permission setting required?

    Thanks

    Hi Ipstenu,

    You are awesome!
    I can display the background image now!!

    Thanks!

    Hi Ipstenu,

    Although the background image is solved but is it available to share the menu in multisite? as now it seems to re-create all of the setting in the new site, is it correct?

    Thanks

    and i have already customize the menu setting at the site#1 but it did not effect on site#2, when i want to go customize the site#2, where should i find the related file?

    yeah…i fixed it finally.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘how the images retain in multisite’ is closed to new replies.