WordPress Importer
How I solved problems with Importer timeouts (3 posts)

  1. runbei
    Posted 2 years ago #

    Importer failed when I tried to import a large file with over 350 posts and pages - many of which were long articles.

    I solved the problem by using this wonderful, simple XML file splitter to divide the downloaded Export file from the old site into smaller chunks: http://www.rangerpretzel.com/content/view/20/1/

    The exported file was 4+ MB. I split it into files of 200K. The process was instantaneous, and when I checked a few of the resulting XML files using an online XML file validator, they passed with flying colors.

    I then tried to import the 22 small files. The first 10 files imported flawlesly. But then I began having timeouts. I used the file splitter to create smaller files, and was able to import a few of them without problems. But there were still a few fails.

    I ended up creating smaller and smaller export files by reducing the output size until I specified .02 MB as the output file size. I was left with 15 files of 64 to 82 KB that would not import. But each of those files contained just a single article that I can find in the old site and transfer manually. MUCH easier, overall, than transferring 350+ posts and pages by hand, or trying to persuade my hosting company to increase its timeouts, or dickering around with PHP/MySQL files and hoping for the best.

    If I had it to do over again, I would do pretty much the same - import as many of the larger split-up files as possible. But in the second round I might try reducing the file sizes more drastically.

    Of course, this raises the question: what's wrong with WordPress Importer, that it can't import those last 15 files of 64-82 KB. Clearly, the fault is not with my host company's server settings, but with WordPress Importer or somewhere else.


  2. fastasleep
    Posted 2 years ago #

  3. fastasleep
    Posted 2 years ago #

    ^ only problem with the Mac app is that it has a bug where you can't enter less than 1MB (can't enter 0.9). Used the Win app above via Parallels, trying to get that to work. :/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Importer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic