Support » Fixing WordPress » How I solved my http error Image Upload Problem

  • For the longest time it was a nightmare uploading images. Sometimes it would work, sometimes it wouldn’t. I re-formatted images, sometimes ten different times before WP would accept them in the media browser. I read many, many, posts, reset things, changed permissions on things. I’ve lived with this problem for so long and I finally think I solved the issue.

    If you are experiencing http errors or general cannot upload messages with your media, I would encourage you to try the following.

    1. Access your .htaccess file using FileZilla or any other FTP client. You should see it as soon as you connect to your websites database.
    2. In the .htaccess file, paste the following code right before the final line:

    Options +ExecCGI
    addhandler x-httpd-php5-cgi .php

    This disables FastCGI. Not sure what it is or what it means, but it worked. I’m hosting my site through GoDaddy using X theme.

Viewing 1 replies (of 1 total)
  • Hey there

    Glad you solved your “http error” when uploading images. However, I must tell you that this “http error” is so generic that it can be any number of things. In fact, most of the time that I see this issue with my customers it is due to the “Smush It” Plugin.

    The issue with that plugin and this error is that the API call to Yahoo fails for any number of reasons and this http error is the response in WordPress. But, glad to hear that your method worked for your error!! Good find.

Viewing 1 replies (of 1 total)
  • The topic ‘How I solved my http error Image Upload Problem’ is closed to new replies.