WordPress.org

Support

Support » Themes and Templates » [Resolved] How do you remove the Read More link?

[Resolved] How do you remove the Read More link?

  • Even though I have set my posts to display full text, the “Read More” is displayed at the end of each post. I searched the codex, but the index.php page doesn’t seem to have the same coding as their examples. How do I get rid of “Read More”? Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The index.php doesn’t have the_excerpt where it should say the_content?

    Hi, Lokeswari. I can give you a hand with your problem, but first I need a little information:
    1. WP: a.Link to your site/blog; b. template you’re using; c. WP version
    2. Is the “Read More” tag appearing in your “Home” page?
    3. When you write your posts, are you inserting the following tag: <!–More–> anywhere inside the text?
    If you provide me with that information, I’ll be able to assist you better, 🙂
    Take care.

    Gangleri. No, this is what is has:

    <div class="postContent"><?php the_content(__('continue reading...', 'Eos'));

    Marventus:

    1.
    a. mymusicthing.com
    b. EOS
    c. 2.9.1

    2. Yes

    3. No.

    Thanks.

    Ok. I think I know what the problem is.
    Open your index.php file with the Editor, and change this line:
    <div class="postContent"><?php the_content(__('continue reading...', 'Eos'));

    to this one:

    div class="postContent"><?php the_content(); ?>

    That should do it. If it doesn’t, you will have to use the Excerpt function. Let me know if that works, and if it doesn’t, I’ll walk you through it.

    Wait, I realized that your Read More tag is also called upon from the “postFooter” div as well.
    If you want to get rid of it completely, look for this piece of code in your index.php and delete it:
    <a class="postReadMore" href="[link]"><b><b><b>Read more</b></b></b></a>
    Notice that for the link part you are going to have a php function instead (probably a call to “the_post”).

    I’m taking a look at your blog, and your sidebar is displaying at the bottom of your footer. Make sure you did not accidentally delete any <div> or </div> tags by accident.
    If my solution is not working for you for some reason, try changing back the “content” call to the way it was before:
    <div class="postContent"><?php the_content(__('continue reading...', 'Eos')); ?>
    and only delete the line I told you:
    <div class="postContent"><?php the_content(__('continue reading...', 'Eos'));

    If that still doesn’t work, you can try calling “the_excerpt” function instead of “the_content” function, and adding text in the Excerpt Window of each post in the post Editor. To call the excerpt function, you need to replace:
    <div class="postContent"><?php the_content(__('continue reading...', 'Eos')); ?>
    with:
    <div class="postContent"><?php the_excerpt(__('continue reading...', 'Eos')); ?>

    LMK how that works for you, and we’ll take it from there.
    Good luck!

    Yah. It didn’t work, and I made things worse trying to put it back. I’ve now upgraded to EOS 1.3.10 and things are back to where they started.

    I really appreciate your help, and will take a closer look at your recommendations when I have more time to follow through. I’m just getting started, so I obviously need to be more careful about backing things up before cutting and pasting away.

    Thanks again.

    I’m sorry to hear that, and I’m really sorry I messed up your template! It is pretty difficult to figure out exactly how the template is built without actual access to all the php files, since when you view the source code on any browser, it shows you all the php functions already “processed” into html.
    However, I’m sure the Read More tag is related to that piece of code that I told you about. Also, notice how at the end of your php content call, you have a ‘continue reading…’ command that also controls the way the Read More is displayed and that seems to be referencing a

    Sorry for that: hit enter accidentally and my post was published. I was saying:

    Also, notice how at the end of your php content call, you have a ‘continue reading…’ command that also controls the way the Read More is displayed and that seems to be referencing an internal template command: ‘Eos’, which is the name of your template, right?
    LMK when you give it another go, and I’ll try to give you a hand. If you want, you can send my your template (only if it’s free) to frandeazevedo at gmail dot com and I’ll try it on my WP installation. If it is premium and not restricted, you could also insert the code inside index.php (using the ‘code’ tag in the toolbar).

    Sorry again for all the trouble. Take care!

    No worries – I’m sure it was my mistake and it was easily fixed. Not sure when I’ll get another chance to take a look at this, but if you’re curious, I’ll go ahead and send you a copy of the template. Thanks.

    Ok, so… Since I’m a little obsessive about these kinds of things (and since I really suck at acknowledging defeats), I searched for your template, downloaded the same version you told me you had (1.3.1) and I set it up in an empty blog that belongs to my girlfriend (she wants to move it from Blogger to WP, but she hasn’t had the time to do it yet, so it’s empty: don’t worry, she does not mind, haha).
    Then I edited the index.php file and ONLY deleted this chunk (without touching the content php call):
    “><b><b><b><?php _e(‘Read more’, ‘Eos’); ?></b></b></b>
    Believe it or not, it worked! You can check it out here.
    That should work for you too, unless you made other modifications to the markup that might be getting in the way. If you did, and it doesn’t work, LMK and I’ll take a look at it.

    I forgot to sitck the code between tags. It’s:
    <a class="postReadMore" href="<?php the_permalink() ?>"><b><b><b><?php _e('Read more', 'Eos'); ?></b></b></b></a>

    Yay! I’ll count this as fixed for now, victory is (y)ours. Somehow, the colors on EOS 1.3.10 went bad on me. So I went back to 1.3.8, applied the last change you suggested, and it worked. Thanks for your help and persistence.

    Marventus, this issue has nothing to do with me but I am really proud of you and you are a hero 😀

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] How do you remove the Read More link?’ is closed to new replies.