Support » Plugin: AWS for WordPress » How do you force an audio regeneration?

  • Resolved diywebmastery

    (@diywebmastery)


    I am sure that this never used to be a problem. If I changed the wording of a post, I’d switch Polly off, then re-save the post with Polly switched on. I checked this a few times to see if it generated a new audio and it did.

    Now that isn’t working. When I modify and save a post, I can’t get the audio to regenerate. What is the correct procedure for making an audio regenerate? Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor tstachlewski

    (@tstachlewski)

    Hi @diywebmastery
    Are you using S3 or WordPress server to store files? Also do you have got Media Library support enabled?

    Cheers,
    Tomasz

    Thanks for getting back to me. We managed to figure it out. I am using S3 and CloudFront.

    There was something (not included in the plugin instructions) that we had to set up on CloudFront to make this work consistently. I’ll update what the process was here later, in case anyone else wants to know.

    Plugin Contributor tstachlewski

    (@tstachlewski)

    Oh, I see. Yes. CloudFront is a cache layer in this situation, so if you update the audio (content), there might be some time required to get ‘new audio’ content. What you could do is decrease ‘caching’ time on CloudFront 🙂 But anyway, great that you managed to solve the problem!

    Cheers,
    Tomas

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How do you force an audio regeneration?’ is closed to new replies.