Support » Plugin: Modern Events Calendar Lite » How do we fix conflict with naming page “events”?

  • Resolved programmin

    (@programmin)


    I’m sure this has probably been brought up but I unfortunately can’t find the post here – whenever someone adds a page “events”, the page is essentially broken because of how the “events” type is added by this plugin. Going to edit /events/ page in Elementor gives an error for example.

    Is there any setting or workaround to set this other than making an /events-2/ page?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Have you tried to change Settings->Slugs/Permalinks->Main Slug to something other than ‘events’?

    Yes I have.

    Plugin Author Webnus

    (@webnus)

    Hi @programmin,
    Hi @acicovic and thanks for your reply.

    Always we recommended when you change the slug whole of the plugins, head over to WordPress settings > Permalinks and make sure save it as “Post name” (mostly), save changes.

    However, if you didn’t see any change the first one please follow the troubleshooting:
    For troubleshooting, deactivate all your plugins and let the MEC remain active only, set your theme on default, then reload the page, if the issue was solved, then activate your plugins one by one and your theme, refresh your page and check to see which plugin is causing the issue.

    in the next step, you need to follow the steps explained in this article:
    https://webnus.net/dox/modern-events-calendar/no-event-found-issue-in-modern-event-calendar/

    Please note: If you use the “Post name” for permalinks, we believe the issue should be fixed, I try it on our demo and didn’t see any issue.

    Best Regards

    Thanks! Seems good. Seems like there’s a refresh rewrites that needs to happen in the save code?

    Plugin Author Webnus

    (@webnus)

    Hi @programmin,

    Sometimes yes, the rewrite on permalinks needs to save again.

    Best regards

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘How do we fix conflict with naming page “events”?’ is closed to new replies.