Support » Installing WordPress » How do I up to a Database?

  • Resolved zendim

    (@zendim)


    I created a WordPress site on phpfog, then used git to copy it local. The way phpfog is set up I can’t get to the wordpress database and access it from my localhost installation. I need to set up another database. So far, I haven’t been able to get it to work. Phpmyadmin won’t open.

    Here is where I’m at right now:

    in the wp-config.php file, I’ve changed the parameters “user” to ‘root’ and the password to ‘mypassword’
    in mylini, I’ve changed the password param to ‘mypassword’ and the port to ‘3306’

    in config.inc.php, I’ve changed “user” to ‘root’ and ‘password’ to ”

    When I try to connect to phpmyadmin, I get this.

    Error
    MySQL said:

    Cannot connect: invalid settings.
    phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

    I’ve tried a number of ideas on various forums, but nothing gets me past this yet. Any ideas would be awesome.

    Greg

Viewing 3 replies - 1 through 3 (of 3 total)
  • You cannot connect to your database reomtely unless you have the specific privileges, which 99% you do not have.

    So in that case or you assign new privileges to connect to the database remotely (which I do not recommend for security reasons) or simply make a backup of the online database, and restore it on a local MySQL install.

    How big is the database you are trying to upload?

    Wes Beckwith

    This was actually due to me not having the right password for mysql.

    So, its me being a bonehead. I got it working, but I had to uninstall that wordpress installation and start over, because I had the password wrong.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How do I up to a Database?’ is closed to new replies.