WordPress.org

Forums

How do I set automatic links for specific words? (5 posts)

  1. martinperreault
    Member
    Posted 7 years ago #

    Hi!
    Love WordPress!

    I would like to know how I can setup automatic links fro specific words in my posts. It's long to always to have to
    a) select word
    b) click on link icon
    c) write the http: link
    Is there a way to set specific words and links, and then simply refer to them? Ie.: using [word] would link to a href="http://www.wantedlink.com" target="_blank" ... See what I mean?

    Or perhaps a plugin that detects the words in the post and changes them automatically to the links you preset?

    I looked in the plugins department, but cannot find this feature...

    Thanks!

  2. This plugin appears to do what you want, however some people seem to have problems with it and the latest WordPress version:
    http://www.headzoo.com/alinks

    Might still work though.

  3. martinperreault
    Member
    Posted 7 years ago #

    Thank you! That looks exactly like what I am looking for. I saw the few last comments mentioning some bugs. Hopefully the current downloadable version fixed them. I'll try it and see.

  4. martinperreault
    Member
    Posted 7 years ago #

    An update: I tried ALINKS from http://www.headzoo.com/alinks and I encountered Memory Errors during install. I tried to add more memory to the plugin.php file by adding this code in the file wp-admin:/includes/plugin.php :
    ini_set("memory_limit","25M");

    This has worked in the past when installing plugins that required more memory. But this time, it simply would not work and I couldn't reload the plugins page until I would delete the ALINKS plugin folder.

    Since then I am experiencing problems with the text editor : the VISUAL TAB does not work anymore when I click on it. I only see the code of texts I write...

  5. martinperreault
    Member
    Posted 7 years ago #

    I fixed the Visual Tab problem. It was not related to the ALINKS plugin, but it was related to the EASY TAGS plugin which seems to create a conflict. De-activating that plugin solves the Visual Tab problem.

Topic Closed

This topic has been closed to new replies.

About this Topic