WordPress.org

Forums

wp-greet
[resolved] How do I implement update for the Photocrati redesign of NGG (6 posts)

  1. MarinaYamamoto
    Member
    Posted 1 year ago #

    Urgent message from wp-greet

    Unfortunately Photocrati did a major redesign of NGG and therfore the connecting filters for wp-greet were removed.
    To workaround this and make wp-greet work again please edit nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/templates/thumbnails/index.php

    and change the line with (I don't know how to do this)

    get_image_url($image))?>" to get_image_url($image)), $image)?>"

    Since NGG does not work with all Lightbox-Effects. Please set Gallery -> Other Options -> Lightbox Options to Shutter, if you encounter problems with other settings.

    If someone can tell me where to go find this line that needs to be changed I would be so happy! My site basically revolves around this plugin so for it not to work is a major set back.

    Thank you!
    http://www.MarinaYamamoto.com

    https://wordpress.org/plugins/wp-greet/

  2. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    hi Marina,

    you can either use a ftp client to edit the file (e.g. ftpzilla)
    or do it directly from the WordPress admin dialog

    1. ftp client
    - navigate to your wordpress directory then go to wü-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/templates/thumbnails
    - right click on index.php and choose edit
    - you will see the file in an editor
    - find the line and change as described
    - save the file
    - leave the editor
    - filezilla will ask you if it is allwright to transfer the file back
    - answer Yes :-)

    2. WordPress admin dialog
    - go to plugins -> editor
    - select nextgengallery from the dropdown (top-right)
    - click select
    - add ?file=nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/templates/thumbnails/index.php to the url in the url field of your browser
    - then the file will be displayed in the wordpress editor
    -- find the line and change as described
    - save the file by clicking save

    Hope it helps.

  3. Ekesh
    Member
    Posted 1 year ago #

    Hi,

    i made the change as needed above and my gallery settings are put to shutter but when i get into it it still opens the images with lighbox and not wp-greet.

    I had wp-greet version 3.1 before upgrade. WordPress is on the latest version as well as NextGen.

    your help will be appreciated

    Note: for now i've rolled back NextGen to previous 1.9.6 version and it works.

  4. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Ekesh,

    maybe you selected a template somewhere else in NGG?
    If you like to send me an email with an admin account and I will take a look at it. The email is support ät tuxlog dot de

  5. yiddishwarmth
    Member
    Posted 6 months ago #

    Hello, I hope I can chime in on this same topic as it's related to the original question. When I locate the original line of code to change, it's not exactly the same line of code you have in your instructions.

    Instead of this:

    <a href="<?php echo esc_attr($storage->get_image_url($image))?>"

    I find this:

    <a href="<?php echo esc_attr($storage->get_image_url($image, 'full', TRUE))?>"

    Would I still use your replacement piece of code or does that need to be modified based on this slightly different code?

    Thank you kindly!
    Chloe

  6. tuxlog
    Member
    Plugin Author

    Posted 6 months ago #

    You can still use my replacement.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • wp-greet
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic