Support » Plugin: Product Feed PRO for WooCommerce » How do I hide specific product categories from the feed?

  • Resolved nossileee

    (@nossileee)


    Hi,

    there are some products and categories that I don’t want to appear in the feed, which is sent to Google Shopping.

    I have about 10 categories of bulk products and I DON’T want them to go to the feed and google.

    I have already created rules, but they are not working.

    see how it is:

    https://imgur.com/aok7UvV

    See that I selected some categories, equal condition to -> I selected the category from the list and put it excluded.
    
    I understand that products that are linked in these categories should NOT appear in the feed, but they still do.
    
    Even many remained without appearing, but there were still a few, trying to remove them all, now most have returned again.
    
    Very strange, can you help me with the rules correctly?
    
    How to ignore / remove certain categories from the Feed?
    
    Thank you very much.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor supportadtribes

    (@supportadtribes)

    Hi,

    Thanks for using our plugin and reaching out to us.

    The exclude filters you created seem fine to me, those should work.

    Are you sure your feed is being updated and that it is not being cached by a 3th party caching plugin or your browser so you are looking at an old version of your feed?

    Same problem, but reverse
    I have filtered names and codes, but the file is empty

    The image is like that of nossileee but, as mentioned, in the opposite way

    Thread Starter nossileee

    (@nossileee)

    Hi,

    I put the URL as “exclusion” in LiteSpeed Cache, just to not cache the URL.

    And I accessed the XML and updated it a few times, and I noticed the data change, but those categories that should NOT be in the xml feed, are still there. I waited for hours and it didn’t work out.

    I even deactivated the plugin, I activated it again, but still without success.

    I do not know what to do…

    Thread Starter nossileee

    (@nossileee)

    see how the settings are:

    Feed
    https://imgur.com/V4pUmgQ

    Plugin check
    https://imgur.com/5c7el9W

    Exclude Settings LiteSpeed Cache
    https://imgur.com/5PDdaXu

    It seems to me to be correct.

    Anyway, if I open the XML and search for the word “bulk” there should be none, you can see in the link below that they are there.

    XML feed
    https://imgur.com/VcysErK

    Is there anything I can do?

    I don’t know if I can delete the entire feed and create a new one, but will there be no problems on google?

    Because 90% of the feed has already been approved there.

    Thread Starter nossileee

    (@nossileee)

    I’m creating another feed, and I put the filters like this:

    Does it also work?

    The product that contains the title “A Granel” will be excluded.

    Check?

    https://imgur.com/96O9Vtr

    The feed is still being created, but I searched the XML and found nothing about “A Granel” products nor “Tribulus” both put in the rule above.`

    It seems that way, it worked.

    But in this case I was “lucky” because in all the titles of these products I put “A Bulk” but if it were by category, it seems not to be working.

    What can I still do again.
    It is to create a NEW feed by testing the SAME rules as before, to try to exclude the categories.

    Plugin Contributor supportadtribes

    (@supportadtribes)

    Can you share with us the plugin debug.log so we can see how you configured your feed and if there is anything you did with the category field or its mappings that could cause the category exclusions not to work?

    Instructions on how to retrieve the debug.log can be found here:
    https://adtribes.io/send-your-debug-log-to-support/

    Thread Starter nossileee

    (@nossileee)

    Hello, of course!

    I just generated the file, follow the link:

    https://www.bhlfitness.com.br/wp-content/uploads/woo-product-feed-pro/logs/debug.log

    Plugin Contributor supportadtribes

    (@supportadtribes)

    Thanks for this. There doesn’t seem anything wrong with your feed configuration although I can’t really judge this now as the filters you created based on categories are no longer there. Hence, I still suspect your feed, once created, is being cached and you are looking at an old version of your feed.

    You can test this by making a change to the feed configuration you have in place now. Add a field mapping or a new filter/rule and see if that works after your feed has been updated and if the changes are being reflected in your feed.

    Plugin Contributor supportadtribes

    (@supportadtribes)

    Assuming the issue at hand is sorted and/or our support is no longer required I will close this topic for housekeeping reasons now.

    Don’t hesitate to reach out to us again whenever you need our help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.