Support » Themes and Templates » How do I get Magazine Basic NOT to show thumbails?

  • This may seem like an unusual request, but I don’t want to show thumbnails or image previews on my blog’s home page or category pages. If there’s an image in a post, I only want that image to show up in the post itself.

    Is there a way to do that?


Viewing 4 replies - 1 through 4 (of 4 total)
  • I have exactly the same request – anybody out there with the key to this?
    Thank you!

    I have been looking for the answer to this as well. Any ideas?

    In your magazine-basic theme folder, you’ll see a layout folder. Inside that folder, you’ll see the different theme options, ie. option1.php, option2.php, etc…. Make a backup copy of the option file you are using first, then open your option file using a text editor such as Notepad or whatever you use to edit code files. You’ll see some code that looks like this (in this case I am using code from option1.php):

    <div class="storycontent">
    		<?php if(get_option('uwc_excerpt_content') == '2') {
    				theme_content(__('Read more &raquo;', "magazine-basic"));
    			} else {

    Delete both resize(200,200); lines.

    Different options have different resize numbers but you get the point.

    Also, go to the archive.php file in your theme folder. Back it up, open it, and find this line:

    <?php resize(80,80); ?> It should be at about line 32. Delete this line.

    What this does:

    It deletes calls to the thumbnail resize function. Your post images will still be in your posts.

    Then, go to your theme’s functions.php file. Go to about line 1028, or look for the following code:

    // resize function
    function resize($w,$h,$q=80,$class='alignleft',$showlink=true) {
    	global $more;
    	$more = 1;
    	$content = get_the_content();
    	$title = get_the_title();
    	$theme = get_bloginfo('template_url');
    	if($showlink) {
    		$link = "<a href='".get_permalink()."' title='$title'>";
    		$linkend = "</a>";
    	$pattern = '/<img[^>]+src[\\s=\'"]';
    	$pattern .= '+([^"\'>\\s]+)/is';
    	if(preg_match($pattern,$content,$match)) {
    		if(get_option('uwc_image_resizer') == "on") {
    		echo "$link<img src=\"$theme/thumb.php?src=$match[1]&h=$h&w=$w&zc=1&q=$q\" class=\"$class\" alt=\"$title\" width=\"$w\" height=\"$h\" />$linkend"."\n\n";
    		} else {
    		echo "$link<img src=\"$match[1]\" class=\"$class\" alt=\"$title\" width=\"$w\" />$linkend"."\n\n";
    	$more = 0;

    This is the resize function. It ‘grabs’ an image from your post and resizes it. Delete this entire chunk of code. If you don’t feel comfortable about that, you can comment it out by putting // at the beginning of each line. Hope this helps!

    Thank you that worked great and sorry for not replying sooner!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘How do I get Magazine Basic NOT to show thumbails?’ is closed to new replies.