Support » Fixing WordPress » How do I fix this strange issue with my website’s links?

  • Hi guys,

    On the bottom of the website [ redundant link removed ], at the footer, there are the following links:

    Privacy Policy | FAQ’s | Articles | Blog | Testimonials |Sitemap – but the links go through to 404 pages, SOMETIMES.
    When I tried it now, it worked fine. I have edited the footer area with the correct url’s but, it does not seem to working. Something makes me thing this is some WP setting somewhere.

    Your advise and ideas are appreciated.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    When I look at the links in your footer, they’re mis-entered. For example, the FAQ link is http://146.66.97.132/~fakenotr/privacy-policy/~fakenotr/faqs/. The FAQ page should be http://146.66.97.132/~fakenotr/faqs/.

    How did you create the links?

    • This reply was modified 1 year, 11 months ago by Steve Stern.

    Hi Steve, Thanks for your input

    I added the footer code, in the template’s place to add it.

    © 2018 Thetha Connect. All Rights Reserved. <a href="~fakenotr/privacy-policy/">Privacy Policy</a> | <a href="~fakenotr/faqs/">FAQ's</a> | <a href="~fakenotr/articles/">Articles</a> | <a href="~fakenotr/blog-vlog/">Blog</a> | <a href="~fakenotr/testimonials/">Testimonials</a> | <a href="~fakenotr/sitemap/">Sitemap</a>

    I see the double one url issue in the link you looked at here — ( http://146.66.97.132/~fakenotr/privacy-policy/~fakenotr/faqs/ )

    In the code at the top, which is in the footer section, you can see that it does not have the double [ ~fakenotr ]. Somehow, something is adding the [ ~fakenotr ].

    Thanks again.

    • This reply was modified 1 year, 11 months ago by Steve Stern.
    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    What do you mean by “in the template’s place to add it”? HOW did you add it?

    I think the URL’s are being re-written by something.

    I went to the Theme’s options, selected footer, and added the HTML in there. Which is where it is supposed to go. It works, but the URL’s are being re-written to double one section of the url.

    Link with example image =
    [ http://i64.tinypic.com/2js2ft.png, http://i63.tinypic.com/2hq5h90.png ]

    You need to use absolute not relative urls.

    "~fakenotr/privacy-policy/" is relative to the page you are on

    "/~fakenotr/privacy-policy/" is absolute.

    "http://146.66.97.132/~fakenotr/privacy-policy/" is also absolute.

    • This reply was modified 1 year, 11 months ago by Simon Prosser.

    Hi Simon,

    What you wrote makes sense, I found a plugin called Velvet that does the following:

    “Velvet Blues Update URLs

    This plugin updates all urls in your website by replacing old urls with new urls. To get started: 1) Click the “Activate” link to the left of this description, and 2) Go to your Update URLs page to use it.”

    I used that to update the urls, and they are OK, but the problem still persists.

    For example: “http://146.66.97.132/~fakenotr/~fakenotr/privacy-policy/&#8221;

    That URL has the “fakenotr” piece in it twice. But the actual site code, which I have checked and rechecked in the Footer section of the theme does not match the above URL.

    Somehow the “fakenotr” is being written in twice.

    Thanks for the input.

    http://i67.tinypic.com/33uxxko.png

    http://i64.tinypic.com/25alnia.png

    • This reply was modified 1 year, 11 months ago by hb7of9.
    • This reply was modified 1 year, 11 months ago by hb7of9.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘How do I fix this strange issue with my website’s links?’ is closed to new replies.