[resolved] How do I enable json module? (6 posts)

  1. Amisanoai
    Posted 5 years ago #

    Hello, how do I enable json module?

    I solved this problem!
    Module Json must be enable in PHP v.5.2.x settings. By default settings - json is disable.
    Thanks to all! ;)))

    I spent many hours today and I can't make it to work.

    What is the easiest way to enable json?

  2. Do you have root access to your server? You need to compile PHP with JSON.

    Then open up your php.ini file. *Only do this if you know what you're doing, make a backup*

    Add the following lines:

    Save and restart Apache:

    If you don't know how to do ANY of that, call your host and ask them to add JSON to PHP :)

  3. Amisanoai
    Posted 5 years ago #

    Thanks for answer but I am developing my blog locally on Windows...

    I accessed the php.net tutorial to compile json but something is going wrong.

    Please tell me if there is an easy way to get the json work while I still try here xD

  4. Amisanoai
    Posted 5 years ago #

    I am tired of developing my blog locally -.-'

    Every time I have one problem. I will upload everything to my web host and make it private while it is not ready yet.

    I have more important thing to do to waste time with configuration x.x

    Thanks for the support anyway.

  5. If you're doing it locally on Windows, then you need to compile your local PHP install for json. (Do mention Windows and localhost in your posts BTW, if you're using it ;) It matters a LOT!)


  6. lindaloustarr
    Posted 4 years ago #

    Same issue, am newbie to wordpress (this version since last year), noticed the issue when trying to drop & drag widgets to no avail. Am using 4 different themes for my site through 3 other folders besides root. Installed wordpress correctly into separate folders with separate files and separate wp-config.php for each with separate databases.

    Called godaddy they wouldn't help with JSON said it was a javascript . . . Completely uninstalled wordpress one by one to be sure my multiple folders weren't causing the issue.

    Downloaded a new wordpress zip file, downloaded winzip just to be sure it wasn't a windows extract all files issue, unzipped, dragged & dropped to my ws_ftp uploader. Tried it on my xp home computer to be sure it wasn't a windows 7 issue (same, couldn't drop/drag widgets in xp either).

    Instead of using ws_ftp auto upload this time, created folders within root itself and uploaded file by file according to ASCII & Binary to root only (no additional folders this time).

    I've trouble shooted from my end all I can & I REALLY need some expertise here. Below is the coding in my php.ini file (which godaddy tech says is current php file)- how/what do I change to get wordpress 3.2.1 to work correctly? I have deleted wordpress so there's nothing to see right now at lindaloustarr.com - Breathe Possibility.

    I went to php.net on the suggestion of godaddy tech and I am out of my league there . . .

    Thank you so very much for your kind & speedy reply :>)
    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 60
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

    ; Only uncomment zend optimizer lines if your application requires Zend Optimizer support


    ; -- Be very careful to not to disable a function which might be needed!
    ; -- Uncomment the following lines to increase the security of your PHP site.

    ;disable_functions = "highlight_file,ini_alter,ini_restore,openlog,passthru,
    ; phpinfo, exec, system, dl, fsockopen, set_time_limit,
    ; popen, proc_open, proc_nice,shell_exec,show_source,symlink"

Topic Closed

This topic has been closed to new replies.

About this Topic