Support » Fixing WordPress » How do I delete the default Home page?

  • Hi, I’m new to WordPress, I’ve got it installed and written my first blog but it appears on bothe the Home page and my new page. In the list of All Pages, Home is not there, so what do I do please?

    P.S. If you can reply, please be aware that I am not computer language savvy, so you need to talk me through it like you are talking to a child!

    Thanks in anticipation.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Did you make any changes in Settings>>>Reading if you want your Home page to be blog page then select first option your latest posts.

    If you want Your Home page to static then select 2nd option and select Home as your front page.

    No, I didn’t make any changes to settings.

    When I first opened my new WordPress, I opened All Pages to create a welcome message on the Home page but there were none listed.

    So I created a new page and started a blog. When I logged out and viewed my site from “outside” I saw my bog on the Home page AND my new page.

    I’ve looked in Settings>>>Reading but only my new page is shown in the second option, no Home page.

    HOWEVER, I’ve found the Home page in Posts, where I’ve been able to edit it as a welcome. But it does still not appear in Reading.

    If you have any other ideas, let me know but many thanks for your reply.


    Please put your website url and a screenshot where it showing as Home page as default page, so we may check it.

    My URL is

    Please read the post above. Sorry, I don’t know how to make a screen shot. Maybe you could advise me how to do this?

    The only page that works is home page and rest is giving me 404 error.
    By default your Home page is your post page anything you post using post label in admin will be posted in this default page unless you made a change in Settings>>>>Reading.

    Home page will not show in 2nd option unless you created a page for your Home you can use any page you create as default page by selecting the 2nd option.

    You can create blank page name it what ever you want no content and use that page as post page in 2nd option.

    are you referring to the 404 page at: ? if yes, please check your permalink structure and check the .htaccess code. . Also, check your site url and home page urls in General settings.
    BTW, to learn more about take screenshot, please go here.

    Hi, the fault is with the Custom permalink. I have read and followed ALL your instructions. I have found that if I use the Default permalink, the site works BUT I want to promote my blog with a Custom permalink.

    I can’t find the .htaccess code but, as I have started WordPress as a Value Application from within my Domain/Host provider, I have referred this bit of the problem back to them.

    If you have any ideas about the Custom permalink (I have definately entered the correct format as per Using_Permalinks), it would be ppreciated.

    Many thanks.

    what type of custom permalinks that you need? whether it should be as below: ,
    if yes, please add the custom permalink structure as:
    also, add the following code into the .htaccess file within the directory where the main index.php of wordpress application located (the folder where your domain is pointing, ex: /public_html , /htdocs etc. where it contains wp-config.php wp-content, wp-login.php etc. files/folders)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    If there is no .htaccess file, create a new one.

    I want to use but Using_Permalinks says not to use domain in custom permalink. I have been using /%pagename%/, not postname. Is that wrong? My postname is the pagename.

    You can view my blog in full at the moment as I have it set as Default permalink.

    Do I find the index.php of wordpress application at my Domain/Host account? I can’t find .htaccess file in my WordPress Dashboard etc.

    Many thanks for your help AND patience!

    Okay then, use the following permalink structure only.
    so that the page will be rewritten as only. please use your hosting account’s file manager or use FTP to verify whether the .htaccess file existed or not. most of the times, if the .htaccess file not present, you will get a message under settings >> permalink structure that the file needed to be updated manually. are you hosted in godaddy unix shared? if yes, click here to get help about FTP.

    Thanks for that.

    Sorry to be so thick but what do you mean by “category” and “postname”?

    I’m new to blogging, so I have assumed tha each blog subject has a new page.

    My Domain/Hosting is with MyQuickDomains. They’re pretty easy to follow with instructions and their support is excellent. I will give it a go and we’ll see what happens!

    Please click here. Assume that it is one of the blog created by WordPress. In that website, you can see ‘General’, ‘computer’, ‘Open Source Applications’ under that ‘WordPress’, Joomla, etc., Also, you can see that ‘Contact us’, ‘About us’, Guest Posting’ in the second menu.
    The top row is called as categories. the bottom menu is called as pages. Pages means static contents. Categories means a section where you can add posts to it for different subjects.
    For instance, go to this post. Here, /open-source-applications/ is parent category, wordpress is its child category. deactivate-wordpress-plugin’ is the post name which I set for the child category.
    Just click on ‘About us’ menu. the url changed to /about-us/ – it is a static page. You can add child pages to it too. but you cannot attach any posts directly to it.
    To do this, please add the permalink structure as mentioned in my last response only. Also, you can activate No-Category-Base plugin too.
    I hope you understood what I explained here. I’m sorry, I can’t explain in any other way.

    That’s excellent. I’m going to try it all now and I’ll let you know.

    Many thanks.


    Well, I’ve followed all you have said and I still can’t get it to work.

    I’ve noticed that when I use the Custom permalink, it changes all the permalinks for my posts to the last one that I have entered.

    I think there is a fundamental problem with the WordPress Value Application that MyQuickDomains has on its system.

    So what I have done for now is post everything on my Home page and sent a ticket to MyQuickDomains for help.

    The .htaccess file was missing from my hosting, so I’ve put it in as you instructed.

    I don’t know where you are in the world but it is now time for my bed.

    Will talk again tomorrow.

    Thanks for all your help.

    .htaccess file is hidden file on linux server and need have Mod_rewrite ON
    If you using a window server then you will not have one.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘How do I delete the default Home page?’ is closed to new replies.