Support » Fixing WordPress » How do I avoid affiliate links

  • The page linked is just one example. When I create hyperlinks in my post, they automatically go via an affiliate site called ‘click.linksynergy’. I do not recall making this choice, and yet I cannot find how to undo it. I am working with a client who wants my link to their website (anchor text in the above page: ‘holiday playsuit’) to be a direct, clean link instead of affiliate. How can I stop my links going via click.linksynergy as they all are at the moment?
    Thank you

    • This topic was modified 2 years, 3 months ago by ailsarenk.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Don’t use affiliate links then?

    It’s your site. How did you add that?

    I am asking how I can stop affiliate links? – they are not a feature I have added consciously, it just redirects automatically.
    I all do it copy and paste the destination link into the ‘add link’ option on WordPress.

    Hi ailsarenk,

    It could be malware or a browser extension you have inadvertently downloaded.

    I can’t see any example links attached, do you have one or a link to your post so I can check this further?

    Cheers,
    Rob

    Hi Rob, thank you for getting in touch.

    The link is in the anchor text ‘holiday playsuit’ on the following page: www.commontoff.com/2018/07/14/summer-lovin-in-comfort-my-ultimate-easy-style-staple/

    You may well be right, a lot of my work with WordPress is by experimenting, so I may not have realised!

    Thanks,
    Ailsa

    Clicking on your ‘holiday playsuit’ link takes me straight to the ‘warehouse playsuits’ page so sounds like it is either malware or a browser extension on your computer.

    What system are you using and which browser? There are a few options to try getting rid of it πŸ™‚

    Cheers,
    Rob

    Oh really? The search bar doesn’t go via click.linksynergy? I use Safari on my MacBook. However, Warehouse, the company I am working in collaboration with, also have the redirect issue and are asking me to fix it.

    Open to any options!!

    Thank you,
    Ailsa

    Just tried in on my iPhone and it redirected via click.linksynergy. I’ll look further into it for you.

    Just to clarify, you’re simply adding the exact link below into WordPress? There are no affiliate tags added on the end or anything?

    https://www.warehouse.co.uk/gb/clothing/jumpsuits-and-playsuits/

    I see you’re using the ‘Disqus Comment System’ plugin.

    I’ve read reviews of this plugin adding affiliate links. Try disabling affiliate linking in your Disqus account:

    https://help.disqus.com/ads/how-to-disable-affiliate-linking

    If that doesn’t work, try deactivating the plugin, clear your browser cache and test the link.

    Let me know how you get on πŸ™‚

    Rob, you hero!

    Thank you so so much for your time, disabling affiliate links on my Disqus account worked… I would have had no idea!

    Thanks again πŸ™‚

    You’re very welcome πŸ™‚

    Glad it fixed the problem.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘How do I avoid affiliate links’ is closed to new replies.