Support » Fixing WordPress » How do I add a an audio file to my blog that people can download?

  • Resolved Showgirl


    I have an audio file that I would like people to be able to download. I am guessing I would need to upload the file to my server through ftp. If this is right, which file do I upload it to?

    If I am totally on the wrong track can someone send me in the right direction please? Is there a plug in that does this?

    Thanks for any help in advance.

Viewing 15 replies - 1 through 15 (of 21 total)
  • I’m looking for the exact same thing. I have a blog posting legal mp3 for download, is there a plugin for this or?

    Just upload it through the normal attachment uploader, same as images. It’ll recognize most filetypes and act accordingly.


    And the download manager will do it? It didn’t work when I tried to upload it normally.

    Normal uploads of audio files using the built in uploader will indeed work fine. Just upload it and then insert it into the post like any other media file.

    Here’s a video demonstration:

    it says “This file is too big, your php upload_max_size is 2mb” what to do?

    Now see, if you’d said that in the first place, then you’d be that much closer to an answer.

    PHP has two settings called upload_max_filesize and post_max_size, which can control how big a file you can upload. The smaller wins.

    Short version: You’ll need to ask your host how you can change these settings for your site.

    To see which setting you need to change, you can do this:
    Make a new phpinfo.php file on your site, and inside it put this line:
    <?php phpinfo(); ?>
    Now load it up in a browser ( It will give you a lot of info about your setup. Look for those two settings there.

    ” * Locate the php.ini file in the folder your upload script resides in. If none exists, install a new php.ini file from the PHP config icon in cPanel. Then, use the File Manager to rename php.ini.default to php.ini
    * In the php.ini file, locate the line called ‘upload_max_filesize = 2M’
    * Modify that entry to read ‘upload_max_filesize = 10M’, or whatever your script requires. (M = megabytes)
    * That’s it!”

    This is got from the help thingy, and did all this. Still won’t work. the same message comes up.

    Re-read Otto42’s instructions.

    PHP has two settings called upload_max_filesize and post_max_size, which can control how big a file you can upload. The smaller wins.”

    Do you know what the post_max_size value is?

    If you would rather attack it like Showgirl wanted to, just create a directory somewhere in your blog and name it “audio”, or whatever you like. Upload all of your audio files via FTP to that folder and you’re done. All audio files are stored in, and retrieved from one location.

    Showgirl, yes, you can upload your audio files via FTP.

    Put them wherever you want on your server, and get the URL of that location. For example

    Now go into WP > Write Post > include a hyperlink to that mp3 file. Anyone can download it from the hyperlink (Right-click, Save As…)

    WordPress will usually automatically make it an “enclosure” on the post, which will also help make the file accessible for download.

    Another option is getting any of the podcasting plugins. A podcast is just another word for a media or mp3 file attached to your post. PodPress is one of the good plugins for this.

    “post_max_size” i changed that too in the php.ini, won’t work. To use the ftp and all of that seems a bit to complicated when I post so often (1 per day), it just takes too long and is not very effective.

    You need to take up the problem with your host. Only they can tell you the correct way to set those two values.

    If they told you one way that didn’t work, then you need to tell them that it did not work. WordPress cannot fix this for you, the PHP settings are higher level than it is.

    Talk to your host. Get them to fix it. Or find a better host.

    Note that you said “that your upload script resides in”. This is unusual, but okay. The WordPress upload script is in the wp-admin folder.

    Okey, they don’t have any email support at, so I guess I’ll have to call them. But thank you all for the help anyway.

    Okey, the php.ini file just were in the wrong folder, so the upload now works perfectly. Thank you all.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘How do I add a an audio file to my blog that people can download?’ is closed to new replies.