WordPress.org

Forums

Quick Cache (Speed Without Compromise)
[resolved] How can I have it not cache the "blog" page. (3 posts)

  1. 12sp
    Member
    Posted 1 year ago #

    I have a static page for my homepage. The page that lists all the blogs posts doesn't update (showing the latest post) unless I clear my cache.

    I understand I can set the expiration to everyday, but I only post once a week to that seems excessive.

    So, I wanted to know if there is a way to make so that page doesn't cache. I remember the older version had a place for that. I like the new version, but it's very techie and I'm scared of screwing something up.

    https://wordpress.org/plugins/quick-cache/

  2. KTS915
    Member
    Posted 1 year ago #

    You need the Pro version for that capability. Then you'd go to Quick Cache > URI Exclusion Patterns and enter the URI for the blog page.

    So if your blog page is at mysite.com/blog/, you'd enter /blog/.

    Bear in mind, though, that this would have the effect of preventing caching on any page whose URL contained the URI /blog/.

  3. raamdev
    Member
    Plugin Author

    Posted 1 year ago #

    The latest version of Quick Cache (v140605) includes many improvements to how various cache files are cleared when publishing or editing a post. I suggest you give that a try and see if that version improves things for you.

    Otherwise, KTS915 is correct: Quick Cache Pro includes a feature called URI Exclusion Patterns that would allow you to exclude a specific URI (e.g., /blog/).

    There is also a feature request open specifically for an option to disable caching for Home Page / Posts Page. You may want to follow that feature request for further updates.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Quick Cache (Speed Without Compromise)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.