WordPress.org

Support

Support » How-To and Troubleshooting » How can I get posts to not land on Home page?

How can I get posts to not land on Home page?

  • I’ve found that if I create a separate template for my posts to land on (articles.php) they still view on the Home page (even though I’ve selected otherwise in Settings>>Reading). So, is there a (step-by-step) way of having posts read on a different page/template (e.g.: articles.php)?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The Blog In Blog plugin should do what you want.

    The Blog in Blog basically just does what many other category shortcodes do. (Place shortcode on page and it creates a list). But the Blog location still does not change.

    All you need to is create a blank page for your blog no content and publish and in Settings>>>Readings select Static pages and front page select the static page want and post page select the blank page you created.

    Hi. I tried that. But, it still uses the Home page.

    I’ve found that if I create a separate template for my posts to land on (articles.php

    You say that you have set template for post page how are you assigning the template to post as when you post there is nowhere to choose template as default is index.php

    govpatel,

    I’m not sure of what your question is. I have page (called articles) which is assigned to a template (called archives.php). In the settings, I’ve selected “articles” as my blog page.

    what ever you post using a post label will automatically display posts using index.php

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘How can I get posts to not land on Home page?’ is closed to new replies.